When app builds in Fusetools, it just shows whitescreen instead of the app


#1

I just started a new app, and when it builds successfully, its just a white screen. I found another thread talking about this, and used uno build -r -tdotnet and it does run and the app builds and displays correctly in that outside window, but in that thread there was never a solution to solving the original problem. Obviously that was for fuse 1.0.1, and it has come a long way since then, am I missing something? I would much rather have live updates on my app rather than having to re-run that console command each time, as well as I would like to try out the layout editor that Fuse offers.


#2

Hey Caleb, FYI, you gotta give us more info and perhaps some code?

Which fuse version, system OS, target mobile OS, command used, etc.

A white screen could be a missing splash, but since its a new app, could be a missing tag in your code.


#3

I am running Windows 10, Fuse version is the latest, so v1.9.0, its set on iPhone 6/7 as the preview. The command was just to build normally, except the command I run to make it work on a separate preview which is ‘uno build -r -tdotnet’ I believe. And my code, it is basically the bare bones just a MainView ( I don’t know if you want me to link it because I dont remember how to make it look like code in here but I’ll put it below irregardless), and then just 2 pages that only have plain text on them.

Here is main view:

<App>

<Router ux:Name=“router” />

<ClientPanel>

<Navigator DefaultPath=“welcome”>

<Welcome ux:Template=“welcome” router=“router” />

<Login ux:Template=“login” router=“router” />

</Navigator>

</ClientPanel>

</App>


#4

I think its your preview command, have you tried the local preview command?
fuse preview -t=Local

I just tested this and it worked, try it and see if you can see anything with either commands.

<App>

	<Router ux:Name="router" />

	<JavaScript>
		module.exports = {
			gotoFirst: function() { router.goto("firstPage"); },
			gotoSecond: function() { router.goto("secondPage"); }
		};
	</JavaScript>
	
	<ClientPanel>
		<DockPanel>

			<Navigator DefaultPath="firstPage">

				<Page ux:Template="firstPage">
					<Text Alignment="Center">This is the first page.</Text>
				</Page>
				<Page ux:Template="secondPage">
					<Text Alignment="Center">This is the second page.</Text>
				</Page>
			</Navigator>
		
			<Grid Dock="Bottom" Columns="1*,1*">
				<Button Text="First page" Padding="20" Clicked="{gotoFirst}" />
				<Button Text="Second page" Padding="20" Clicked="{gotoSecond}" />
			</Grid>

		</DockPanel>
	</ClientPanel>

</App>

#5

Just ran that command, and still got this.


#6

Hmm, seems to be a Windows 10 issue.

Here’s some things you could try: https://windowsreport.com/opengl-problems-windows-10

Perhaps copying the OpenGL file to the fuse installation directory will work: https://www.youtube.com/watch?v=1JQoEZjSA40

I see you have OpenGL 4.6 from Nvidia, maybe its too advanced lol

If all else fails, you could still:

  • build a preview for your device: fuse preview -t=Android or fuse preview -t=iOS
  • download fuses preview app (You can use the preview app as long as your project only contains UX markup, JavaScript and the standard Fuse packages, but excluding Fuse.PushNotifications): Android or iOS

#7

Hmm, yeah those didnt work. So I guess my new computer is just a bit too advanced. Hopefully as Fusetools updates it’ll work again.