White Blank Fuse Preview after executing exploring example

Hi fuseteam.

I have tested several OSs.
One of them had failed to show ‘fuse preview’
Not showing any GUI in preview.
‘fuse preview -tandroid’ is working fine though.

Fuse version : 1.0(build 13426)
Machine & OS : macOS Sierra(10.12.5) - Mid 2010 iMac - ATI Radeon HD 4670 256MB

Does uno build -r -tdotnet -DDISABLE_HARFBUZZ work? This does a local export of the app, so you’ll lose preview capabilities, but it would be helpful to diagnose the cause of the error.

I’ve tried what you mentioned.

‘uno build -r -tdotnet -DDISABLE_HARFBUZZ’ made exploring.exe.
It showed the exploring example window but not in Fuse Studio.

Problem is still remained.

Ok, then we’ve at least located the problem. It’s an issue with our font renderer on your particular CPU. There is unfortunately no good workaround for this right now. You only options are:

  • Run preview on device only
  • Run a local export with the command I gave you above. This does not give you preview functionality though, so you’ll have to rebuild for each change.

We are currently working on a fix, and will update this thread as soon as we have one.

These are my system information for any help.
Thank you.

iMac(21.5-inch, Mid 2010)

CPU 3.06 GHz Intel Core i3

Memory 4GB 133MHz DDR3

Graphic ATI Radeon HD 4670 256MB

Thanks jbvoice, I’ve added that information to our issue now.

We’ve found out that there were several problems with the prebuilt libraries that we ship with Fuse when it comes to compatibility with older Mac models.

I’ve submitted a pull request for a fix, and you can follow its progress here. It’s too late for it to be included in the coming patch release since that’s already being tested, but it will likely be included in the release after that. If you’re feeling brave you can try a local checkout of the fuselibs branch in the pull request linked above in the meantime.

Wow, thanks!

The Fuse 1.0.1 pre-release, available at https://www.fusetools.com/downloads/channel/qa, now allows you to pass defines to the preview command again, so another workaround for this issue that should work is to start Fuse with fuse preview . -DDISABLE_HARFBUZZ. The fix mentioned above will be included in the release after 1.0.1 if all goes according to plan.

Thanks, Olle!

I’ll try and then provide you feedback.

Olle Fredriksson wrote:

The Fuse 1.0.1 pre-release, available at https://www.fusetools.com/downloads/channel/qa, now allows you to pass defines to the preview command again, so another workaround for this issue that should work is to start Fuse with fuse preview . -DDISABLE_HARFBUZZ. The fix mentioned above will be included in the release after 1.0.1 if all goes according to plan.

Fuse preview is still not working in 1.0.1 pre-release version.

Did you use fuse preview . -DDISABLE_HARFBUZZ to start Fuse as I mentioned in my reply?

Olle Fredriksson wrote:

Did you use fuse preview . -DDISABLE_HARFBUZZ to start Fuse as I mentioned in my reply?

What i did was ‘fuse preview -DDISABLE_HARFBUZZ’.
I just copied what you mentioned and then tried.
Finally I got preview~!!

Thanks.

Hello Jbvoice, hi Olle, I have the same issue with an old MacBook. Could you tell me where did you applied the line “fuse preview . -DDISABLE_HARFBUZZ”. Was it in the TERMINAL? I tried a couple of times there, with Fuse open or closed, and the answer whas “fuse: Could not find a fuse project to preview” in all cases. Hope you can answer me, thanks in advance.

@hemisferio2 you execute that in Terminal, yes. Specifically, you need to cd into the project directory and run it there.

Easiest way to open the right folder is when you have Fuse open, click Project in the menu and then Open in Terminal. In the Terminal window, run the command specified.

Hope this helps!

Hi Uldis, thanks a lot! It worked! I just have to close Fuse (once the project is open in Terminal, I used your tip) and then Fuse opens after the instruction is executed in Terminal.
It even shows the visual updates I do on Sublime.
Once again thanks, enjoy your norse summer, and winter greetings from Córdoba, Argentina.

Hi, blank preview too on Win 10 x64, Fuse Version 1.1.0 (build 13798).

uno build -r -tdotnet works.
Any idea? Thanks.

@jsmi on Windows, it’s a different issue. Check this thread and post your hardware details there.

Hi Uldis, the problem in the thread is different, because uno build -r -tdotnet works on my PC.
Here the hardware details: Intel® i5-2520M CPU 2.50 GHz. (Win 10 Pro, 64-Bit)

Thanks.

@jsmi, and what happens when you launch preview with -DDISABLE_HARFBUZZ flag?