Preview crashes on Windows 10

Hey there,

When trying to preview an app, even a blank one, it builds the code successfully and the window opens and then I get a “Fuse has stopped working…” window with no error information.

Here’s the output from my console.

fuse preview Build started: FullCompile Configuring (9,887.93 ms)

Compiling syntax tree (7,745.79 ms)

Generating code and data (29,199.51 ms)

Build completed in 47.27 seconds. 0 Warning(s) 0 Error(s) Build ended GL_VERSION: 4.5.0 NVIDIA 353.54 GL_VENDOR: NVIDIA Corporation GL_RENDERER: GeForce 610M/PCIe/SSE2

And then it crashes.

I recall it working a few weeks ago.

I can get it to build an apk for Android just fine though.

Strange, I started using “fuse build -t=dotnetexe --run” to run my app on Windows because previewing wasn’t working, and it built fine. Then I tried “fuse preview” some time later and it ran without crashing.

Sometimes I get a “fuse: Project not found” error when I run “fuse build” which is strange because “fuse preview” works just fine and I am in fact a fuse project folder.

Just a quick question, did the crash problem go away completely?

No it didn’t but I can get it to work if I try hard enough. Usually the first time I run a preview it crashes, but sometimes if I close Fuse and reopen it, the preview will start working, sometimes if I run a dotnet build and then try previewing, it will work, sometimes it crashes again. I haven’t figured out what makes it work consistently. For all I know it could be a memory allocation error and it actually just works randomly.

I’ll post it here if I figure out what’s stopping it from crashing.