Fuse Preview Not Working (actual preview not rendered, white screen only)

Fuse Version: 1.0.0 (build 13426)
Operating System: Windows 10 Pro 64 bit

Hello Fuse Team,

I’d like to report that I am not able to view my applications properly (at all) every time I execute “fuse preview” or via the Atom plugin.
When I run or call the command, Fuse Studio opens, tells via the “Log” pane that it is Configuring, Compiling and Generating Code until Build is Completed. However, after that, no actual preview of my application appears.

Though note that “fuse build --target=Android --run” works.

Thank you very much! Hoping to hear from you soon.

Hi Armand,

please see if the 2 highlighted answers on this post solves it for you.

Hello Uldis

Here are the results of my tests:

  • Even after installing Fuse 1.0.1, fuse preview still did not work as it’s supposed to
  • Executing the command “uno build -r -tdotnet -DDISABLE_HARFBUZZ” rendered a working application preview (in a way that looks to be the ones in the pre 1.0.0 versions) that is also interactive

My cents:

  • Though the second result gave me what I need, the failure of the first one is still to look about

If you need anything else for the resolution of this, please let me know :slight_smile:

Building for dotnet target usually means that you don’t get the hot reload functionality on file saves. I don’t think that’s what you need.

1.0.1 solves the problem with passing -D flags, so you can run commands like fuse preview . -DDISABLE_HARFBUZZ which would open the Studio, allow you to have hot reload and NOT use harfbuzz for text rendering - which is a workaround for the “white preview” issue.

1.0.1 does not include the fix for the “white preview” issue. To have that, you need to use a local checkout of fuselibs, as noted in the post I linked. If you go this route, you should be able to run Studio without adding any -D flags and it should just work.

Considering all of the above, I would like to ask you to do some testing and see if any one of those approaches make your local preview show up.

Since there is a potential for another, unrelated problem that we are aware of, please send us the model of your graphics card / GPU.

I’ll check on your items above and will do some testing.

I am actually using the integrated graphics of my Intel Core i7-2600k CPU which is the HD Graphics 3000 and currently has OpenGL 3.1 as per my recent checking.

If it helps, I’m actually able to fuse preview my applications on Fuse version 0.36.1 with the same OS and hardware setup.

Hey Armand,

The final fix for the problem in the post that Uldis posted actually only applies to macOS, so if you can work with us a bit to diagnose your problem, which might not be fixed yet since you’re on Windows, we’d be really grateful.

The first thing you could try is to build using:

uno build -r -tdotnet

(That is without turning off the Harfbuzz-based text renderer.)

Does that work? Do you get any error messages or stack traces?

Hello Olle,

I’ll be really glad to help! I’m actually investing in learning and working on this platform, it’ll be great to contribute something and make it work - specially for my use.

I executed your command and was actually able to have an interactive preview of the hikr application I was testing on. Though let’s note that the live updates on changes with my source code does not apply. (as what its supposed to do, I guess).

No error was displayed.

If you need anything more, please feel free to tell me so.

(I actually reverted to version 0.36.1 before our test as it was what worked for me before and just installed the 1.0.0 one for the test)

Hey Armand,

Thanks for testing! Then we know that it only applies to preview. Another thing to check is if the problem was introduced in Fuse 1.0. Could you try downloading 0.37 to see if preview is blank there too?

Hello Olle,

Sorry for taking longer to reply. I only get to use my personal computer when I get home from work. I’ll do my best to give you as much as I could.

Here are the results of my tests:

1.0.0 - “fuse preview” is not working (as discussed above)

0.37.0 - “fuse preview” resulted with 70 errors (refer to the attached logs)

0.36.1 - “fuse preview” worked as intended (I’m actually using this as it is the most stable for me now)

Hope this helps!

Hey again Armand, and thanks for your patience!

It appears that the errors you got with 0.37.0 were network errors, which can happen from time to time. If you could try that again it would be helpful. Some big architectural changes in Fuse were introduced in 0.37.0 so if preview doesn’t work there we know where to start looking.

If preview doesn’t work in 0.37.0 it would also be of interest to know if uno build -r -tdotnet works with that version. That would help us isolate the problem even more.


Hey Olle,

No worries. I hope to be helpful to you.

Executing “fuse preview” the third time (latest testing) still resulted with the same 70 errors that I had attached before (all my tests gave the same errors). Please note that I am actually juggling between our test versions (1.0.0 and 0.37.0) by installing and uninstalling them and it appears that every time I’m on 0.36.1 I am not experiencing any problems (even the probable network ones).

Executing “uno build -r -tdotnet” resulted with a lesser error count of 6 (refer to the attached).


Hey again Armand,

Thanks for testing. Can you paste the output of uno config with 0.37 installed, to see if there’s an issue with any config variables?

Hello Olle,

Please refer to the attached for your request.


Hey again!

There was a problem with the package feed used in 0.37 that should be fixed now, so please try again. :slight_smile:


Hello Olle,

I tried 0.37.0 again with “fuse preview” and non of the 70 errors before actually appeared. It also seems to have configured or installed some things.

However, even if the build has been completed, it still shows a plain white screen with no actual preview of application.

Also, executing “uno build -r -tdotnet” successfully rendered my application as opposed to our previous testing with the same command in 0.37.0 a few days ago.

Tell me if you need anything. Regards!

Hey Armand,

Thanks! Then we know that the problem was introduced in 0.37.

Just to rule out problems with the apps themselves, have you tried a simple app like the following (which should show a red background)?

<App Background="#f00" />

Hello Olle,

As for my most recent testing, “fuse preview” still shows an empty white screen (without a preview of my application) and “uno build -r -tdotnet” was again able to render a preview of the app (a plain red background).

I guess we can rule out the problem with the applications themselves.