[PREVIEW] Fail to autoreload / update preview

UPDATE: Invalid bug! Read 3rd post.

Howdy everyone?

I’ve expected this bug in the past but fixed it through the daemon IIRC. Now I have fresh installation of Windows 10 Pro (Licensed), with Sublime Text + Fuse (latest build).

  Copyright (C) 2016 Fusetools```

Basic ```<app></app>``` with text/label component won't update on local preview when pressing Save (as in saving the file). Reproduced the same bug on local preview through CLI with ```fusetools preview``` and also through Sublime Text plugin. I also tried running ST with Administration rights but same problem occurs. Changing text for example does not do anything. Basically nothing you save does not get updated.

I tried to reset the device several times on local preview through Fuse -> Reset but it stays the same.

The only thing that actually works is restarting the preview like Fuse -> Quit, and then calling the ```fusetools preview``` or through Sublime Text again (so full preview restart). 

I'd like some input here. 

* System: Windows 10 Pro
* Text editor: Sublime Text 3
* Fuse version: 0.30.0
* Target: Local preview

**Reproducing step:**
* Create new project over Fusetools
* Start local Fuse preview (cli / st plugin )
* Update your code in Sublime Text
* Save in Sublime Text
* Local preview stays the same (not updated)  
What could I try and can I deliver anything else for you?

I just tested and autoreload works when saving in Notepad for example. The application does get refreshed and is updated.

Okay, welp! So I google-fu and found the same thread made by me here which is kind of funny. Anyway, I would like to note that this is not the same installation ISO. And also, the preview work on most of our computers, but this is the second time it’s happening so I had to report it because beta :slight_smile:

The thread replicates the same problem like this right now.

Closing this one. I don’t think it’s issue with Fuse but rather with Sublime Text. By following the steps in this answer on StackOverflow, the Sublime Text now indeed updates preview on saving.

The author tho didn’t mention that if you want to update this, go in Sublime Text and then at the menu Preferences -> Settings - User, and then adding the proper key and value to true. It should look like this:

	"color_scheme": "Packages/Theme - amCoder/amCoder.tmTheme",
	"atomic_save": false

Pretty odd, but glad to hear it worked out! :slight_smile: