[BUG] [LIVE PREVIEW] Not updating automatically

Just reinstalled my Windows 10 on my developing machine. With new installation comes a dev environment too.

Sublime Text 3 is installed (registered version | latest build)Fuse tools is installed, plugins, and Android SDK too.

Steps to reproduce:
-> Open Fuse
-> Create new project
-> Open in Sublime Text 3
-> Open local preview
-> Change anything (like add <Text> for example)
-> Save

Result of bug:-> Nothing changed in local Fuse preview


Operating system: Windows 10 Pro
Processor: Intel Celeron 2957U 1.40Ghz x 2
System type: 64-bit OS

$ fuse --version
Fuse version 0.20.3 (build 6549)
(Latest version)

Additional notes:

I also tried using fuse preview from commandline. Same problem occured, the local preview is not updated after a save. 

Build results:
Configuring (16.76s)
Compiling syntax tree (8.15s)
Generating code and data (41.64s)

Build completed in 66.57 seconds.
    0 Warning(s)
    0 Error(s)

# Build complete.

Output:    GL_VERSION: 4.3.0 - Build
Output:    GL_VENDOR: Intel
Output:    GL_RENDERER: Intel(R) HD Graphics

Do you happen to have a firewall (like the default Windows 10 network permission panel) that stops network traffic in any way? Even the local preview uses network traffic to send changes.

The local preview acts on file changes, so does the preview update if you just change the .ux files from any other text editor?

Hey Bent!

Actually, I did have deafult Windows 10 firewall turned on. I allowed Fuse to go through firewall and also disabled firewall but same thing happens, the preview is not updated.

But, your second trick worked. Trying to edit .ux in notepad, the preview updated. So it had to do something with Sublime. What could it be?

Thank you very much! :slight_smile:

This is really strange. Fuse preview updates when the files change on disk, and are not depending on e.g. the Sublime plugin sending it a message to update. So which editor you use should not matter, but in this case clearly it does.

Could it be that Sublime is unable to save the file properly for some reason? Can you please try to make a change in Sublime, save, then open the file in Notepad and see if the change is actually there in the file on disk?

Hey Anders, sorry for late reply, I was busy these days. Since this problem occured I switched to Atom (Editor). It works flawlessly without this problem, tho’ switching to editor to make thing work is nuts, I couldn’t find a proper solution so I used Bents’ advice.

The changes in Sublime Text are actually saved. I’ve tested it by editing something in Sublime, then saving, and then opening Notepad and opening the file without closing the Sublime Text. The change on preview did not occur but the file is indeed saved in real-time.

I know you guys aren’t supposed to know whats wrong with Sublime but this is really a strange issue.

Thank you for the help.

I am experiencing the same issue using Textmate on OS X 10.11.5

I am getting the FW dialog and accepting incoming traffic twice on launch. The first change I do is reflected in the app, but subsequent changes are not.

If I kill all Fuse processes and relaunch, it works once (1) again.

$ fuse preview
Fuse 0.21.0 (build 6650)
Build started: FullCompile
Configuring (6.04s)
Compiling syntax tree (2.49s)
Generating code and data (4.23s)

Build completed in 12.79 seconds
Build ended
GL_VERSION: 2.1 INTEL-10.14.66
GL_VENDOR: Intel Inc.
GL_RENDERER: Intel HD Graphics 4000 OpenGL Engine

Everything works fine on my OS X (El Capitan), latest version, tho I do use Sublime Text on it too. This is really strange.

I can confirm that live works when using Atom, both when starting the preview from the menu command and from Terminal. I have tried both with the Fuse plugin enabled and disabled.

It appears that Fuse isn’t picking up on file changes from Textmate. I don’t experience this issue with Gulp watchify, if that is of any help.

Medo, we shipped a file watcher improvement in v0.21, so I guess the issue you had was solved with that improvement.

Sebastian, are you using v0.21?

Emil: Fuse 0.21.0 (build 6650)

Thanks for letting me know :slight_smile:

I’m gonna test and see if I am able to reproduce the issue in textmate.

Sebastian, I’ve found the bug, and a fix is schedule for the next release. Unfortunately, I’ve no workaround, except to use another editor.

Emil: The update did fix the problem. Fuse now works with the Sublime as well as Atom. Thank you kindly. Issue is resolved from my side.


Emil, thanks for the feedback! I’ll use Atom for the time being. Will be missing Textmates awesome search feature though, but won’t be a problem when starting up my project ;D

Sebastian: This has been fixed in Fuse 0.22, so as soon as that ships, you can go back to Textmate again! :slight_smile:

However, now that you’re using Atom for the time being, make sure to check out the Fuse plugin for it! (“Preferences”, “Install”, “Search Packages”, “fuse”)