Local Preview not Hot Reload

Hi Fuse,

I am using Fuse with Sublime Plugin and before updating to 0.12.1 I could see any errors logged in both terminal, sublime console and Build Tab when Fuse Local Preview is Hot Reloaded on save. Thus allows me to know if there are any mistakes in my app. But after update I am no longer able to view any errors logged, unless I once again run preview local build which conflicts with Fuse Hot Reload feature, all I see in the inital build details.

Small Bug but causes fustration and would like the Fuse team to be aware.

Is this going to be fixed along with the version that has Android Preview fixed?


Hi Elizabeth,

Does the panel that says - Auto-reload result - pop up in Sublime at all when you save one of your UX files?

Have you tried first checking for updates for the Sublime plugin (“Check for updates” from the fuse tray icon), and then restarting Sublime Text?

Hi Lorents,

Yes, the panel says Auto-reload result in Sublime but that is all there is. In previous versions it would also log and display whatever error I have once I made a bug change so that I know there is something wrong, now I would not know unless I rebuild the local preview and that’s when the error gets logged and dispalyed.

Yes, I have checked for updates using the fuse tray icon. I am currently on the latest fuse version (0.12.2).

I have also tried reinstalling the plugin manually to the latest but the same issue persists.

Hi Elizabeth,

Could you upload the logfiles found at ~/.fuse/logs to https://www.dropbox.com/request/ZgndLtJQm5eGzG9cicGK

Hi Emil,

Thanks for the reply.

I have done just that. Uploaded both fuse.log and fuse.sublime.log.

Just so you and your team know: I’ve tried intentionally typing the ux wrong, missing class definition …etc and causing errors in js but the only log error that I ever get is for js syntax errors.

There is one thing I do notice, if I pay close attention, is that if my code is perfect … once I save the local preview, it would flicker. If the screen stays still after I save, that means there is something wrong but I just don’t know what and would have to scan through everything to find it. :frowning:

In previous versions I remember they were logged.

Errors such as this:

Unexpected fatal error! Please report this to us.
Build started: FullCompile
....\Documents\Fuse\SearchBook\MainView.ux(119): E8001: There is nothing named '38' in this scope, and no global resources with that alias. 
C:\Users\Owner\Documents\Fuse\SearchBook\MainView.ux(119,1): Error E8001: There is nothing named '38' in this scope, and no global resources with that alias. 
....\Documents\Fuse\SearchBook\MainView.ux(119): E8001: Multiple definitions of class 'Title' in the project. There is another one on line 99
C:\Users\Owner\Documents\Fuse\SearchBook\MainView.ux(119,1): Error E8001: Multiple definitions of class 'Title' in the project. There is another one on line 99

Hope this helps your team.



Thank you for uploading the log files. However the log files looks fine though, couldn’t find anything related to the issue.

Just to be sure if I have understood the problem. The issue is that when you do something wrong in UX (eg. missing a closing tag) the Auto Reload list stays empty, when saving? And is this happening for all projects you have tested?

Thank you for your patience :slight_smile:

Yes, you are correct. The issue is that at all times the Auto Reload List stays empty. This has been happening for all projects … including examples.

Anyhow, the good news is, today after updating Fuse to 0.12.3, the Auto Reload List works! :smiley:

For mistakes such as:

'<' is an unexpected token. The expected token is '>'.

The 'Panel' start tag on line 54 position 3 does not match the end tag of 'App'.

'Panel' does not have a property called 'Error'

the '=' character, hexadecimal value 0x3D, cannot be included in a name.

There is nothing named 'Click me!' in this scope, and no global resources with that alias

etc. are logged under Auto Reload List

But I have found errors such as:

'MyButton' can only inherit one base class

Multiple definitions of class 'MyButton' in the project. There is another one on line 54

Names must be unique within each document scope. In this scope 'MainView' starting on MainView.ux line 1 the name 'backButton' is already used for Text on line 168

etc. are not. You would not know unless the local preview does not reload and you decide to rebuild and see why.

Hope this helps.



It’s good that it works better after the update.

I think the three remaining issues are expected, as in not fixed yet. However I’ll raise the priority of them.

Again thank you for reporting all the issues you had!

Thank you. Happy to contribute with my best efforts throughout Fuse’s game changing journey. :slight_smile: