Black Screen with iOS simulator

I just tried building an app I’ve been working on to iOS but the Xcode simulator just shows a black screen with the apple logo. After some googling, my best guess is this is because there is no “main interface” set in the Xcode project. I have successful built and run the app on android without issues. What am I missing?

Hi Youssef,

Thanks for your report. Sorry to hear the simulator isn’t working for you. Can you provide some more info:

  • Does it also happen when running an empty app?
  • What are you using to build the project (fuse preview? uno build?)
  • What simulator (device and iOS version) are you using?
  • What version of Xcode are you using?
  • What version of Fuse are you using? Has it worked previously?
  • I just tried the fuse example project and it didn’t work either.
  • I’m using fuse preview -t=iOS
  • I tried using most of the devices and I tried various iOS versions and no combination worked. The app works fine on my physical iPhone though. It’s just the simulator.
  • Xcode version 8.3.2
  • I’m using fuse 0.35.0. This is my first time using the iOS preview.

Hi Youssef,

Thanks for providing information about your setup. I just tried the example app in preview in a simulator and it worked here on a similar (but not identical) setup.

The black screen with the Apple logo suggests to me that the simulator itself isn’t able to boot, meaning that the Fuse preview app hasn’t even started yet. Perhaps you could try following the steps in this forum post and see if they help.

If they don’t, it’d be useful to know if you are able to run apps not made with Fuse in the simulator. If you create a new empty app project in Xcode, can you run that?

Thanks for your patience!