Fuse not running

Trying to preview app on iOS, and once it builds, it opens Xcode. I click the play button to open the emulator, and once it runs, I get a “Fuse not running” message, with an image of two kids arguing.

Two more links on the bottom, change IP and try again.

Fuse is running, so dont know what is causing it.

Here’s a screenshot.
I’ve got MacOSX 10.12 with Fuse 1.1.1


Cant get the image to show.

Here’s the imgur:

Do you have the local preview of that particular project running in Studio?

Have you tried to run fuse kill-all, followed by uno clean in the project folder, and starting fresh again?

Thanks Uldis,

I did both, and now it’s just stuck on Connecting to computer.

I’m trying to connect to the GPS example from your Samples github.

Is the device you’re previewing on connected to the same [wifi] network as the computer?

Could it be that the network has a very restrictive firewall policy that doesn’t allow its clients to connect to one another?

I’m trying to run it on the iOS emulator. So it’s on the same PC, therefore on the same WiFi network.

I can disable the firewall if you think that will help?

Sure, please try that. And try to see if the problem persists on another network.

Ok, disabled firewall, no change.

It stands on connecting to computer.

Other suggestions I can try?

Update: Tried no WiFi, that didnt work either.

I turned on WiFi again, and tried browsing in Safari on the emulator. It works. The emulator is connected to the internet, but not connecting to fuse. On the same network. On the same pc.

Another question on top of that.

When I do app preview in Appcelerator, it starts the iOS emulator and runs the app.

When I do app preview in Fuse, it starts XCode, and then I have to click compile for it to run the emulator.

Am I doing something wrong?

Can you please run ifconfig to check your public IPs, and then check which IPs are listed in the connection failure screen? Just to rule out that Fuse is detecting the wrong IP or something like that.

You could also try to do telnet <your ip> 12124 in a terminal, to verify that Fuse is listening for connections. If you get “Connection refused” there is a problem. If you get a connection, Fuse is accepting connections, and you can just press Enter to return to the terminal.

Furthermore, do you have a physical iOS or Android device you could try to run preview on, just to check if the problem is universal or limited to the iOS emulator?

Here’s the ifconfig output:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
	inet netmask 0xff000000 
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
	nd6 options=201<PERFORMNUD,DAD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
	ether 98:01:a7:ac:7d:8b 
	inet netmask 0xffffff00 broadcast
	media: autoselect
	status: active
	ether 4a:00:06:da:14:e0 
	media: autoselect <full-duplex>
	status: inactive
	ether 4a:00:06:da:14:e1 
	media: autoselect <full-duplex>
	status: inactive
	ether 4a:00:06:da:14:e0 
		id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
		maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
		root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
		ipfilter disabled flags 0x2
	member: en1 flags=3<LEARNING,DISCOVER>
	        ifmaxaddr 0 port 5 priority 0 path cost 0
	member: en2 flags=3<LEARNING,DISCOVER>
	        ifmaxaddr 0 port 6 priority 0 path cost 0
	media: <unknown type>
	status: inactive
	ether 0a:01:a7:ac:7d:8b 
	media: autoselect
	status: inactive
	ether 36:68:da:a9:26:fd 
	inet6 fe80::3468:daff:fea9:26fd%awdl0 prefixlen 64 scopeid 0x9 
	nd6 options=201<PERFORMNUD,DAD>
	media: autoselect
	status: active
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000
	inet6 fe80::8880:d7cc:9575:9400%utun0 prefixlen 64 scopeid 0xa 
	nd6 options=201<PERFORMNUD,DAD>
utun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
	inet6 fe80::5b2b:401a:4ea7:734e%utun1 prefixlen 64 scopeid 0xb 
	nd6 options=201<PERFORMNUD,DAD>
utun2: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
	inet6 fe80::74f1:c2ca:4676:3ab3%utun2 prefixlen 64 scopeid 0xf 
	nd6 options=201<PERFORMNUD,DAD>

So I cannot telnet to or

I dont see the error screen on the app any more after I did Uno clean.

So now that we know Fuse is not listening to connections, how do we resolve it?

Btw, I do have an iOS and Android device I can test on.

When you’ve just verified that local preview is running, but you cannot telnet to Fuse, please check the following:

  • Do you have the Fuse icon in the macOS status menu?
  • What’s the output of ps -ef |grep -i fuse? There should be a process /Applications/Fuse.app/Contents/MacOS/Fuse daemon in that list.
  • What’s the output of sudo lsof -PiTCP -sTCP:LISTEN? There should be a process Fuse there, saying *:12124 (LISTEN)

For some reason I dont see Fuse in the top menu, but I do see it in the docker (dock).

Output of grep:

ps -ef |grep -i fuse
  501 47392     1   0 Mon07AM ??         0:00.00 /Applications/Fuse.app/Contents/MacOS/Fuse daemon
  501 47693     1   0 Mon07AM ??         0:31.29 /Applications/Fuse.app/Contents/Fuse.app/Contents/MacOS/Fuse
  501 59561  1341   0 10:48PM ttys001    0:00.00 grep -i fuse

Output of lsof:

mtmfs        94  root    3u  IPv4 0xdd6aff90822301e7      0t0  TCP localhost:49152 (LISTEN)
mtmfs        94  root    5u  IPv4 0xdd6aff9082230adf      0t0  TCP localhost:49153 (LISTEN)
Arduino_C   895 john    5u  IPv4 0xdd6aff908c2d9ccf      0t0  TCP localhost:8991 (LISTEN)
Arduino_C   895 john    6u  IPv4 0xdd6aff908c2d6ff7      0t0  TCP localhost:8992 (LISTEN)
Adobe\x20   985 john    8u  IPv4 0xdd6aff908c4213d7      0t0  TCP localhost:15292 (LISTEN)
adb        1494 john    6u  IPv4 0xdd6aff908c4225c7      0t0  TCP localhost:5037 (LISTEN)
iTunes    16380 john   30u  IPv4 0xdd6aff908fdca8ef      0t0  TCP *:3689 (LISTEN)
iTunes    16380 john   31u  IPv6 0xdd6aff9074dc4c3f      0t0  TCP *:3689 (LISTEN)
zotero-bi 22523 john   28u  IPv4 0xdd6aff908fdccccf      0t0  TCP localhost:23119 (LISTEN)
zotero-bi 22523 john   33u  IPv4 0xdd6aff908c421ccf      0t0  TCP localhost:23116 (LISTEN)
zotero-bi 22523 john   35u  IPv4 0xdd6aff908ed401e7      0t0  TCP localhost:19876 (LISTEN)
Fuse      47392 john    7u  IPv4 0xdd6aff908c41f8ef      0t0  TCP localhost:12122 (LISTEN)
Fuse      47392 john   25u  IPv4 0xdd6aff908fdce8ef      0t0  TCP *:12124 (LISTEN)
node      52913 john   14u  IPv6 0xdd6aff908475e17f      0t0  TCP *:3000 (LISTEN)
Skype     56673 john   87u  IPv4 0xdd6aff90918f65c7      0t0  TCP (LISTEN)
Dropbox   58440 john  139u  IPv6 0xdd6aff9074dc517f      0t0  TCP *:17500 (LISTEN)
Dropbox   58440 john  140u  IPv4 0xdd6aff909d544ff7      0t0  TCP *:17500 (LISTEN)
Dropbox   58440 john  166u  IPv4 0xdd6aff90a0adf3d7      0t0  TCP localhost:17600 (LISTEN)
Dropbox   58440 john  173u  IPv4 0xdd6aff908ed3eff7      0t0  TCP localhost:17603 (LISTEN)

I put together a video of the issue and how it happens here:

From the video, you can see the following: I do Preview > iOS, then Xcode starts, then I click play to run the emulator, then it stops.

Btw, I did get a timeout finally, and the IP is that of my PC, bot WiFi and

Thanks for all the details! It looks like the Fuse daemon is indeed running and listening on port 12124 as it should, but it’s strange that you can telnet to it, and that the status menu icon isn’t showing.

Just to rule out a few other things:

  • Does the example you’re trying to use work in local preview?
  • Have you tried to just launch Fuse, create an empty app (“New Fuse project” in the dashboard) and see if that works in local and iOS preview?

If none of that works either, could you please try to run fuse kill-all followed by fuse daemon and paste the output of those commands too?

Status menu was showing, but I think it got lost after the 1.0 update?!?

The iOS preview was never working, since 0.3 since I first installed it.

On the observation side, Arduino is observing on localhost, while fuse seems to be on *.

Now, I made a new lank project, and:

  1. Local preview works (displays blank white page)
  2. iOS preview does not work (times out to connecting)

After the commands, I got:

Running at port 12122
Client connected: Proxy
Client connected: Sublime Text 3
Client connected: Code Assistance Service
Client connected: Fuse Tray

The iOS preview failed, but I think it’s cause its now on 12122 and not on 12124.

I can see the status bar icon now.


Did another test, just to check if iOS emulator is communicating with the PC.

I ran a simple python webserver on port 8000 serving an index.html file that only says “it works” when you load it.

So I opened safari, pointed it to localhost:8000 and it loads the page.

So emulator is talking to the pc on localhost. It also works on the WiFI IP.