Preview not working

I am just starting out with fuse so if this sounds stupid, im sorry. Now to the question: everytime i attempt to preview my app, it appears to build just fine but as soon as its finished it just disapears, nothing else shows up and i cant preview anything. any help will be greatly appriciated. Thank you in advance.

Is this when you do a local preview or on a mobile device? If it’s on a mobile device, what kind of device is it? And are you on Windows or OS X?

Also, how are you starting the preview: from the command line, the fuse dashboard GUI, or from inside the text editor?

If you haven’t yet done so, could you try a fuse preview from the command line, inside the project directory, and let us know what it prints out?

Hi I am having the same problem.

It happends in the local view I have tried starting a preview from the dashboard and from inside the text editor.

Pretty much i just beed following along with the installe and getting started video.

Please try a fuse preview from the command line, inside the directory containing your project, and paste the resulting output log here.

I have the same problem since version 0.10on MAC OSX!

I tried to start the local preview from command line like Remi suggest and got the following error message:

fuse: Failed to create a unique directory in /Volumes/Daten/Samples/Fuse/signup-concept/build/Local: Source and destination are not on the same device

In my case it tourned out that in my case fuse in version 0.10 can’t deal with my setup where the projects and samples are on another device.

Question: Is this a bug? Has the project to be on the same device as fuse?

Hi Sven, that was indeed a bug and has been fixed in the latest release (0.11 - it’s out now)

This is what i get when i try to do a preview. i even instalted .11 and i am still getting the same result.

Configuring (7,370.28 ms)

Compiling syntax tree (5,272.78 ms)

Generating code and data (20,877.53 ms)

Build completed in 33.55 seconds. 0 Warning(s) 0 Error(s)

Build complete.

Output: GL_VERSION: 1.1.0 Output: GL_VENDOR: Microsoft Corporation Output: GL_RENDERER: GDI Generic

I am also getting a sreen stuck on “Hoast is loading project”, which didn’t happen 1-2 qa builda ago. No errors reported.

cberevenanu: have you tried the latest 0.11 release?

Hey, yeah. I have probably skipped one or two qa builds, so I don’t know when the issue started. Actually, sometimes the project loads, but on occasions (pretty often) it remains in loading state. Mac OS, by the way, latest version.

Update: all preview builds failing on XCode 7.3, including the swipe-gesture-reveal sample.

#import <UIKit/UIKit.h>
#import "UIResponder+FirstResponder.h"

static __weak id currentFirstResponder; <-- cannot create weak reference in file using manual reference counting

@implementation UIResponder (FirstResponder)

+(id)currentFirstResponder {
    currentFirstResponder = nil;
    [[UIApplication sharedApplication] sendAction:@selector(findFirstResponder:) to:nil from:nil forEvent:nil];
    return currentFirstResponder;

-(void)findFirstResponder:(id)sender {
    currentFirstResponder = self;


Hello everyone! I’m using Fuse 0.9.11 on Mac OSX and can’t get the preview to on my device. I keep getting a “Failed to connect to proxy: Connection refused…172.20.xx.xx:1244 No route to host” error. Local preview works fine though

I just update to Fuse 0.11 and am still having an issue with Android preview. Only this time, if I sudo the preview command, the app won’t launch at all. I now get “Unfortunately, myApp (preview) has stopped” on phone and the following in terminal:

Build completed in 67.44 seconds.
    0 Warning(s)
    0 Error(s)
Build ended
Installing APK on 1 device(s)
Launching actitity 'myApp'
D/dalvikvm(25366): Late-enabling CheckJNI
I/ActivityManager( 1007): Start proc com.myApp for activity com.myApp/.myApp: pid=25366 uid=10126 gids={50126, 3003, 1028, 1015}
D/myApp   (25366): SUT: false  CML: false  SDK: 19
D/dalvikvm(25366): Trying to load lib /data/app-lib/com.myApp-1/ 0x41bfcab8
D/dalvikvm(25366): Added shared lib /data/app-lib/com.myApp-1/ 0x41bfcab8
D/dalvikvm(25366): No JNI_OnLoad found in /data/app-lib/com.myApp-1/ 0x41bfcab8, skipping init
D/dalvikvm(25366): Trying to load lib /data/app-lib/com.myApp-1/ 0x41bfcab8
D/dalvikvm(25366): Added shared lib /data/app-lib/com.myApp-1/ 0x41bfcab8
D/dalvikvm(25366): No JNI_OnLoad found in /data/app-lib/com.myApp-1/ 0x41bfcab8, skipping init
D/dalvikvm(25366): Trying to load lib /data/app-lib/com.myApp-1/ 0x41bfcab8
E/dalvikvm(25366): dlopen("/data/app-lib/com.myApp-1/") failed: dlopen failed: cannot locate symbol "_ZN8V8Simple7Context14ThrowExceptionEPNS_5ValueE" referenced by ""...
W/dalvikvm(25366): Exception Ljava/lang/UnsatisfiedLinkError; thrown while initializing Lcom/myApp/myApp;
W/dalvikvm(25366): Class init failed in newInstance call (Lcom/myApp/myApp;)
D/AndroidRuntime(25366): Shutting down VM
W/dalvikvm(25366): threadid=1: thread exiting with uncaught exception (group=0x4193bd58)
E/AndroidRuntime(25366): FATAL EXCEPTION: main
E/AndroidRuntime(25366): Process: com.myApp, PID: 25366
E/AndroidRuntime(25366): java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "_ZN8V8Simple7Context14ThrowExceptionEPNS_5ValueE" referenced by ""...
E/AndroidRuntime(25366):     at java.lang.Runtime.loadLibrary(
E/AndroidRuntime(25366):     at java.lang.System.loadLibrary(
E/AndroidRuntime(25366):     at com.myApp.CppManager.LoadLibraries(
E/AndroidRuntime(25366):     at com.myApp.myApp.<clinit>(
E/AndroidRuntime(25366):     at java.lang.Class.newInstanceImpl(Native Method)
E/AndroidRuntime(25366):     at java.lang.Class.newInstance(
E/AndroidRuntime(25366):     at
E/AndroidRuntime(25366):     at
E/AndroidRuntime(25366):     at
E/AndroidRuntime(25366):     at$800(
E/AndroidRuntime(25366):     at$H.handleMessage(
E/AndroidRuntime(25366):     at android.os.Handler.dispatchMessage(
E/AndroidRuntime(25366):     at android.os.Looper.loop(
E/AndroidRuntime(25366):     at
E/AndroidRuntime(25366):     at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(25366):     at java.lang.reflect.Method.invoke(
E/AndroidRuntime(25366):     at$
E/AndroidRuntime(25366):     at
E/AndroidRuntime(25366):     at dalvik.system.NativeStart.main(Native Method)

By the ways someone might want to correct the proper spelling for “activity” that apears when running the preview command.

I discovered that the despite preview having issues

fuse build -t=android -r

command works fine.


The problem on iOS is a known problem due to a sudden break of backwards compatibility in an Xcode update, and we are working on rolling out the solution.

We apologize for the inconvenience. Thanks for reporting!

A new build of 0.11 that (hopefully) fixes the Xcode 7.3 issues is now available on the QA channel. Any feedback on whether it works/fixes the issue is greatly appreciated!

This build will be promoted to the official beta once we get some feedback on the issue being resolved. Thanks a lot for reporting!

Yo, local preview still has an issue, but as examples start ok, it may be something that changed and just broke my (and a few other projects). Need to dig into it more.

XCode is building ok now, good job!

On running on the phone, though, I get the same “Host is loading project” blocking screen. Need to see what this is… :frowning:

This thread is discussing several issues, here’s a summary: