white sceen showing in iOS


#1

hi,

Is anyone else having this issue with the splash screens in iOS?

when running the app in debug/release, first i see the black screen (fuse’s launch image) and then the white screen for about ~0.5 seconds and after that i see the app.

I ran the tutorial hikr app on the ios device and saw the same white screen.


#2

Hi ParkJun,

exactly what command do you use to run the app on device? If it’s preview then some delays during startup are to be expected of course; the rest may be device-dependent. What device are you using that has the problem?


#3

I connected the iPhone-5s to my Mac.

the first way : i used “Export” menu in Fuse to run the hikr app.

when i run the app,
black screen -> white screen(~0.5 sec) -> hikr splash page

the second way : To make a release build, i used “fuse build --target=iOS --configuration=Release” and then i open the generated project in Xcode, ran the hikr app.

when i run the app,
black screen -> white screen(~0.2 sec) -> hikr splash page


#4

And what happens if you disconnect the device from the computer and then launch the application right from the phone (as opposed to building from XCode)?

While connected, there is some debugging going on in background even for release builds, and a startup delay can still be expected.


#5

please see the frame from 3 to 4 seconds.
(Stop playback and move by 1 frame)


#6

I’m actually wondering if that might be the Video tag to blame. Have you tried removing it from Pages/SplashPage.ux to see if that has any effect?


#7

There are any news about this?

With the hikr example I have the behaviour described by ParkJun on iOS and on Android doesn’t show the black/white screen but it seems that it has a little delay before it launches the app, but it can be ignore.

On my app, which is bigger and has more functionalities and components (I don’t have video) it takes a lot of time to start the app in Android and in iOs it shows the black screen, then the white one and sometimes it skips the splash screen. I tried to remove the splash screen and go directly to the main page and still have the same behaviour.


#8

@Ana_Almeida, did you solved It?


#9

Overall, I’ve tried to reduce the stuff I was doing when initialising the app. On Android, it still has a delay, but on iOS I used LaunchImages to “hide” the time the app takes to start.