Launch delay on iOS

[Running fuse 0.26.0 on iOS 10 on an iPhone 6 (developing on OS X El Capitan)]

I have a small, pretty trivial, two page dummy app (Attached ZIP file. I’ve built it using fuse build -t=ios -adebug. I’ve noticed that when I run the app, sometimes there’ll be a non-trivial delay between the time I tap the icon and the time the app loads.

I’ve recorded an example and attached below. You’ll notice the icon going a bit darker about 2.5s into the clip. That’s when I’ve tapped the icon to open the app. There’s like a good 1.5s to 2s delay before the app actually opens. Sometimes that delay is up to 4s. It’s inconsistent, though…sometimes there’s no delay.

Any idea how to avoid that delay or what’s going on to cause it? Are other users experiencing similar delays?

P.S. - I’ve also tried explicitly adding launch images to the unoproj file, but that doesn’t seem to help. There’s still a delay before bringing up the launch image.

Hey Atish, and thanks for your report!

Does the delay disappear if you stop the Xcode debugger, disconnect your device from the computer, and start the app again? I tried your app and that does the trick for me. We’ve seen this problem occasionally in the past, and the solution has been to stop the debugger. See this post on Stackoverflow for more info.

If that doesn’t solve your problem we’ll have to do a more in-depth investigation.


The delay is still there once I’ve disconnected from my computer.

Hey again!

I’m trying to replicate your setup but haven’t been able to reproduce the issue yet.

After some detective work (googling Stackoverflow), I found this. Could that be it? That is, do you have a large number of provisioning profiles installed on your device? Apparently that can cause slowdowns similar to what you describe.


Awesome find!! I think it was the fact that I had too many provisioning profiles. I just deleted all of them, re-installed the app and consistently get an immediate launch!

I think this can be resolved. However, it would be good to understand why only my Fuse apps were afflicted with this delay. I have other apps I have (or am in the process of developing) that use the same profiles and they launch without delay.

Thanks again for the find!

That’s great!

I have no idea why it was affecting the Fuse app specifically (I don’t think I’ve even seen an app affected by this), but will mark this as resolved anyway.

Thanks again for the report and see you in the other thread. :slight_smile: