Fuse 1.4 on macOS High Sierra 10.13.1 - fuse preview not opens

  • Fuse 1.4.0 (build 14778)
  • macOS High Sierra 10.13.1

When running macOS Sierra, and entering fuse preview in the console, I usually saw Fuse UI startup with mobile app UI.
Today I’ve upgraded to macOS High Sierra, and when I type in fuse preview into Terminal, I see only this:

Fuse 1.4.0 (build 14778)

Preview UI is not opening, however I see FuseTools icon in the Dock.
When I click, FuseTools icon in the Dock, FuseTools UI opens, and I need to select a project to run.
When I select project to run, it runs as usual, and I see output in the Terminal.

Expected behavior:

  • I should type fuse preview in Terminal, and should see FuseTools UI running my project.

By the way, I’ve tried to remove FuseTools completely, downloaded latest version and installed it.

Still I have the same problem.

Can you please send us your logs?

You can send them privately using this link https://www.dropbox.com/request/ZgndLtJQm5eGzG9cicGK

Anders Schau Knatten wrote:

Can you please send us your logs?

You can send them privately using this link https://www.dropbox.com/request/ZgndLtJQm5eGzG9cicGK

Submitted fuse.log file.

Thanks! I’m can’t find any good hints in the log however. Could you please try to do the following?

pwd; ls; fuse kill-all && fuse preview

Then paste the full output of that, and send the log again.

A few other things you could try which would be interesting to know the result of, is to do fuse preview <name of unoproj>, and fuse preview <absolute path to unoproj>.

I’ve submitted file fuse-24.11.2017.log

added console output the the end of the file

one time preview started as it should, I think when I specified absolute path. Then I specified relative path fuse preview file-name.unoproj and then again fuse preview /abs/path/project.unoproj but this time it didn’t start.

Hi, unfortunately there’s not much more I can do with this, since there is no useful information in the logs or the output. I have however added some additional output for Fuse 1.5, so if the problem persists in the that version, we might be able to figure it out then.

In the mean time, you’ll have to start preview from the Fuse UI, or on the command line using fuse open <name of unoproj>.

Ok, thank you, I’ll open from UI

fuse open ActionDrawerExperiments1.unoproj do not starts project, it behaves the same as fuse preview, but it detaches output from Terminal I guess

Hum, that’s interesting! What happens if you do /Applications/Fuse.app/Contents/Fuse\ Studio.app/Contents/MacOS/Fuse\ Studio ActionDrawerExperiments1.unoproj?

Anders Schau Knatten wrote:

Hum, that’s interesting! What happens if you do /Applications/Fuse.app/Contents/Fuse\ Studio.app/Contents/MacOS/Fuse\ Studio ActionDrawerExperiments1.unoproj?

This time Fuse Studio opens and runs my project.

I’ve submitted new file fuse_25.11.2017_poul.log with Terminal output and fulse.log

Anders Schau Knatten wrote:

Can you please send us your logs?

You can send them privately using this link https://www.dropbox.com/request/ZgndLtJQm5eGzG9cicGK

Darbar guru hazari lal ji wrote:

Anders Schau Knatten wrote:

Can you please send us your logs?

You can send them privately using this link https://www.dropbox.com/request/ZgndLtJQm5eGzG9cicGK

already sent, see my previous message

Hi, and sorry for the late reply. This gives us a bit more of a hint as to where the problem could be, but I think we have to wait for Fuse 1.5 with the additional log output to be able to get to the bottom of this. Please reply in this thread when you have tried with Fuse 1.5, it should be out in a few weeks.

Submitted new logs

FileName: fuse_preview_no_not_start_14.12.2017.txt

I’ve installed version 1.5

This is really strange, and we’re almost running out of things to try here. Just to verify that there aren’t any issues with Fuse’s settings, can you please try to rename ~/.fuse and try again?

I’ve removed ~/.fuse but it didn’t help. :frowning:

Yesterday I’ve upgraded to macOS High Sierra 10.13.2, upgraded XCode. And now fuse preview opens as expected. Problem solved. Thanks!

That’s great to hear! :slight_smile: Thanks for reporting back.