Sublime Text won't launch from Fuse dashboard and plugin does not provide color highlighting per visual design

Environment: Fuse version 0.21.0 (build 6650) => purposely downgraded because latest version as of now has a config problem and fails to build for Android. OS: OSX El Capitan 10.11.6 Sublime version: 3 (Build 31134) Fuse plugin version: not listed in Sublime Package Explorer

I have a working installatin of Sublime Text 3 but clicking on the “Open in Sublime Text” does not open Sublime. When I open it manually, I get some of the hints with elements and attributes but I am not getting the color highlighting of the directory view or the code elements themselves in source files. Additionally, clicking on the code element does not seem to highlight the visual element in the simulator window to inspect its spatial arrangement.

To troubleshoot, I’ve gone through the slack channels and previously posted forums. I have tried numerous times to remove the package and deleted all of the Fuse files in the ~/Library/Application Support/Sublime Text 3/Installed Packages directory and also added the fuse path to my $PATH variable to my ~/.bash_profile file and re-sourced my shell but that didn’t seem to help.

I’d appreicate insight on what else I can try


First of all, which exact issue are you having with Fuse 0.22 that made you downgrade to 0.21? If this is about the failing fuse install android command, please upgrade to Fuse 0.23 which fixes this and several other issues.

What does fuse install -s sublime-plugin say?

If you have a .ux file open in Sublime, hit Cmd+Shift+p and start typing “Fuse”, do you then get a list of Fuse commands? If so, what happens if you select Fuse: Preview local from that list?

Thanks for the update! My previous issue was the failure to build for Android.

Based on your reply, I’ve completed the instlallation of Fuse 0.23 and have verified that I can successfully build for Android. As for Sublime, running fuse install -s sublime-plugin yields this output

$fuse install -s sublime-plugin
Fuse 0.23.0 (build 7041)
# Verifying install status of sublime-plugin
Checking for update
Package up to date
sublime-plugin is installed.

I tried removing the Fuse package and got this error in Sublime’s Package Control. Error loading syntax file “Packages/Fuse/BuildView.hidden-tmLanguage”: Unable to open Packages/Fuse/BuildView.hidden-tmLanguage. I’ve attached the screenshot of the error in case it provides any valuable insight.

I then proceeded to remove the FuseVersion package before reinstalling with this outcome.

calvin@~/Documents/Safezone/Projects/fuse/scratch-pad/basic-layout$ fuse install -s sublime-plugin
Fuse 0.23.0 (build 7041)
# Verifying install status of sublime-plugin
Sublime plugin has not been installed
fuse: sublime-plugin is not installed.
calvin@~/Documents/Safezone/Projects/fuse/scratch-pad/basic-layout$ fuse install sublime-plugin
Fuse 0.23.0 (build 7041)
# Starting sublime-plugin installer
Installing sublime plugin...
Successfully installed the sublime plugin
# Done installing sublime-plugin

After uninstalling, and reinstalling I can see the Fuse plugin commands available in the Command Pallete as before but I am still not gettig the color highlighting or the synchronized selection between Sublime Text and the Fuse Preview window when an element is selected in the markup. At this point, the Fuse commands are available in the Sublime Text command palette so it appears I am getting a partially successfuly installation but some of the editor and Fuse preview feature seems to be failing or suppressed.

Can you please zip up and send me ~/.fuse/logs? I might be able to gather more information from your logs. If you upload them to, they will only be accessible by the Fuse team.

Sure thing. I’ve just uploaded “” per your message.

I can’t see anything wrong in that log. As far as I can gather, starting a local preview from the Sublime Text plugin works, but selecting an element in Sublime Text doesn’t make it highlight in prevew? Can you please verify that you have “Select element at caret” enabled in the “Fuse” menu bar in Sublime Text?

What happens if you in your preview window menu do “Fuse -> Design Mode” and click the elemnts in your app, do you get the selection highlight then?

Do you get no syntax highlighting at all? Can you please attach a screenshot of Sublime Text when this happens?

Anders, thank you for identifying the issue with my Sublime Text and element selection synchronization. Activating “Select element at caret” indeed resolved what I was previously observing with no selection in the Preview window. Do you know why anyone developing with Fuse would want that setting to be “False” by default?

Perhaps training issue for me but what remains a challenge is that I am not getting the Sublime Text highlighting. I have attached my screenshot for reference.

BTW, not being able to launch Sublime from the Fuse Dashboard is not a problem for me since I am happy launching from the command line. Let me know if there are any other diagnostics you’d like me to perform.

That checkbox is supposed to be checked by default, I’m not sure what went wrong with that in this case.

I’m not sure what could cause you to miss syntax highlighting. I think I’ll have to wait until next week with investigating, when our Sublime Text plugin expert is back.

Do you get code completion by the way? If you for instance enter

    <Panel Alignment=""/>

then put the cursor between the "" and press Ctrl+Space, du you get a list of alignment options? Note that it might take a little time for Sublime to update the suggestion cache the first time you start completion for a new app.

What exact command do you use to launch Sublime Text from the command line?

When I use CTRL+SPACE, I do get code completion. Thanks for that assertion.

From command line, I navigate to the root project directory where the UNO project file exists, and launch via sublime ./

What does which sublime print?

It prints this due to me creating a symlink as follows.

calvin@/usr/local/bin$ which sublime
calvin@/usr/local/bin$ ls -al | grep sublime
lrwxr-xr-x    1 calvin  admin      61 Apr 24 16:58 sublime -> /Applications/

In troubleshooting, I tried to remove the fuse plugin and reinstalled it. In doing so, I’ve now lost code completion that I previously had and have also lost my Fuse Plugin from the Command Palette. Upon starting up Sublime at the root of Fuse project, I now get this new error.

Is this the expected contents of the directory I should see when I navigate in Sublime to Sublime Text|Preferences|Browse Package…? Personally, I wasn’t expecting to have the packages installed under my user login “calvin” and also wasn’t expecting to have the Fuse.sublime-settings file to be here or nested in the /user directory

as shown.

Please advise on what I can do next to get Sublime Text and Fuse working as my development environment?

As for launching Sublime Text from the Dashboard, Fuse expects to find it at the standard


but you seem to have it installed at


This will be configurable in a future version of Fuse, but it’s not a top priority atm.

I am not sure what went wrong with installing the package, but it looks like you currently don’t have it installed at all. It is expected to be installed in

~/Library/Application Support/Sublime Text 3/Installed Packages

I think you would be best off if you moved Sublime Text to the default installation directory, and then tried the steps in the FAQ to re-install the plugin:

I’ve followed the reinstallation steps and now have Sublime Text installed at the standard location for OSX, namely at


I’ve also followed the reinstallation steps for the Sublime Plugin and it’s now installed at

~/Library/Application Support/Sublime Text 3/Installed Packages

After doing this, I am able to launch Sublime Text from the Fuse Dashboard and all seems to be working well including launch, command palette, color highlighting as well as code completion. Thank you!

Woho! \o/ Glad we got that sorted! :slight_smile:

I’ll update the FAQ to recommend people to have Sublime Text installed in the default location.