Skipped frames


In our app we have a lot of Skipped frames while previewing on Android (preview/release) builds. We searched the forum for a solution and tried to optimize animations as suggested by the community and fuse Devs but we already don’t use many animations except Navigator, PageControl and some <Change Color/> on <Clicked>. We can provide the project if you can send us a private dropbox link.

Any suggestions would be appreciated ! :slight_smile:



That’s strange. What Android device are you using? There are some known issues with particular Android devices that are being worked on.

You can upload your project here:

If you are working on a commercial project and need this fixed on a tight schedule, we recommend contacting Fuse for premium support (

Hello and thanks for the quick reply!! We are testing our app on a Samsung Galaxy S4 (GT-i9505) and on a Samsung Galaxy S5. On both devices we have skipped frames. Also we tested it on an iPhone 4S but on the iPhone we didn’t have skipped frames… at least we didn’t noticed any serious lag.

I uploaded a rar file with name Fuse.rar

I updated today to the latest fusetools version 0.26 build 7741 and i had one issue. Without changing anything in the code; when performing different searches i get an empty space before the first moviecard (see photo below). I checked everything from not properly cleared Observables to UX things but couldn’t find anything. I then rolled back my fusetools version to 0.25.5 (build 7677) and the problem in that build was solved ( with the same code same everything ).

Fotis, thanks for reporting, but it is very hard to make any sense of this without seeing a complete code test case. Is this even related to the topic of this thread? I recommend posting your issue in a spearate thread, with a reduced test case in code illustrating the problem. Thanks

I posted that here because i have already uploaded my code to you through the dropbox link above so you can test it.


Is there any updates on the skipped frame issue ?


No updates on this issue specifically, but each new release includes many general optimizations. There are several significant optimizations in the release pipeline that are likely to help this issue. Let us know if this issue persists after Fuse 0.29.

Version 0.29 is not available for us at least right now. The issue still persists on version 0.28. I still have skipped frames.

0.29 is expected to go into pre-release-testing (#pre-release-testing on the Fuse Slack community) early next week. Sorry for the wait!