Preview iOS Not Connecting To Host

I’ve rebuilt, trusted, changed, everything on a sample project to be able to edit it in real time on my iPhone.

Every time I build and open the app it says it’s connecting to the host and then theres a picture of two boys fighting saying it failed to connect.

Is that my fault or a bug?

Have you made sure your iPhone is connected to the same network as your computer?

Yep! And I’ve checked my IP. Both my iPhone and Mac are connected to the same Wifi

Hey, could you please try to run fuse event-viewer before exporting and running preview on iOS. Also does local preview work?

You can also try to restart Fuse by quiting Fuse from tray.

General info about your system may help, as OS X version, Fuse version and result of running ifconfig.

I just updated to .8.5 and I’m having issues with local and iOS which is a major bummer.

Here’s my fuse build and my OSX version


Sounds like a bummer for sure :frowning: did you try the event viewer as Emil suggested? Hopefully that will spit something useful out!

Hey Jake, I fixed the Local preview issue. I’m still working on the iOS preview. I’m able to edit it using the inspector on my mac, so I’m not too upset about missing out on the preview. I just want to be able to show prototypes in upcoming videos on a couple different devices.

I’m about to try the Event-viewer route, I’ll post what comes up!

It worked! Thanks Jake and Emil for the help!

Glad you got it working! What was the issue, exactly?

I’m not entirely sure… but here’s how I fixed it:

I reinstalled the .8.5 update.

I restarted my mac

Opened Fuse via terminal

ran Fuse event-viewer

Preview iOS

Ran in xCode

And it worked!

I guess reinstalling must have helped with connecting to the host, maybe something wasn’t connected or installed correctly?

Yeah, that’s probably it. The event viewer is mainly to get a log of stuff Fuse is doing, which helps us actually see failures if they occur, so I don’t think that specifically was what fixed it. Might also have been some cache issues if your device was trying to connect to your computer with an outdated IP addy, which I’ve had happen before moving around at trade shows etc :slight_smile:

Glad it works!