App doesn't load in Local/iOS Preview even after successful build


Again and again I get ‘connection error’, while selecting ‘app preview’ from the dashboard. For the example todo project. The preview doesn’t load and asks me to change IP.

But after trying a few times (without changing anything) and relaunching Fuse - the preview works. Or I have to restart my Mac, then it works.

I am on Mac 10.9.5 with a 3.7 GHz Quad Core and 12 GB 1867 MHz DDR3

Very frustrating to have a GUI which behaves so erratically. What might be the reason for this?

bets regards,

Alok D.

I would say I have had a similar experience. When it doesn’t open I think it’s becuase of a coding mistakes and will make changes trying to debug the file when there is nothing wrong with the actual code and it’s the preview that isn’t working.

Quite a frustrating way of working when you are frequently changing code to make little alterations but then the preview won’t load.

I hope you can enhance this feature in the future.

Keep up the good work.

Thanks for the feedback! I’ve created an issue for us to look into this.

Hi Anders,

Good you are having a look. Have the same problem today. The preview doesn’t load.

Just wanted to tell you, I tried using Fuse yesterday at home on my MacBook Pro and it worked beautifully. I am not behind a firewall at home.

At my workplace I am behind a firewall - could that be the reason? I tried pinging ( as mentioned in your other Form thread ‘Preview Local : Cannot connect to the proxy’) and it works.

Do let em know if anyhting else can be done.

Great work - you guys are doing!

best regards,


It’s unlikely that a firewall is the issue if it works sometimes and sometimes not.

The firewall you’re talking about, is that a company firewall that your computer is behind? Or is it firewall software running on your computer itself?

The Fuse preview app does not try to connect to the internet, only back to your computer.

When it prints the IPs it’s trying to connect to, can you try to ping both/all of them?

Hi Anders,

Thanks for the quick response.

I am behind a Company firewall. No firewall installed on my machine.

Pinging to all of the IP works. But not if I use something like

I get this -

Interstingly, if I I click on ‘Go Offline’ on the above - I get the screens from the Example App -

Even if I create a new app from the Dashboard and choose ‘Fuse Project’ - I get the above including the example app!!




Not able to install Fuse on OS X Yosemite (v 10.10.4), 2.7 GHz Intel Core i7 8GB 1333 MHz DDR3 with Intel HD Graphics 3000 512 MB

On my Mac OS 10.9.5 I am able to run the Preview only after restarting the machine - every time!

What kind of errors are you getting when you try to install on the 10.10.4 machine? If the installer itself fails there should be a log there.

As for the other machine: does this mean you can only do 1 preview and after that it will consistently fail? Could you send us the log file at ~/.fuse/logs/fuse.log ? You can upload it to

Hi Remi,

Thanks for having a look at this.

I have uploaded the log files from the 10.9.5 machine. Today too I had to reboot my system to make the Preview work.

I am updating my Yosemite machine to El Capitan and then will report back.

BTW, can you please direct me to resources on use of other back-end cloud services, now that PARSE has announced closure of its services.

best regards,


Thanks for the log. We’re looking into it and will keep you updated.

Did things improve (or at least change behaviour) on the other machine after the OS upgrade?

As for other backend services I don’t think we’ve published any specific examples, but similar integration approaches (as the one used for Parse) should work for a lot of the other things out there. In the end the details come down to which one you chose and what APIs they provide. (This seems like a decent overview of at least some of the different services out there:

Hi Remi,

Thanks for the response. I will look up the resources on Parse alternatives.

Things are better on El Capitan.

One thing I have realised is that if I put my machine to ‘sleep’ instead of ‘log out (user)’ at the end of the day…the fuse icon remains on the tray and I don’t need to reboot my machine. Maybe that helps?

best regards,

Alok D.