Fuse Previews no longer work (Fuse (beta) release #0.5.3269)

Hi there, I just updated to Fuse (beta) release #0.5.3278 and now when I try to locally preview any Fuse project, I’m met with a blank preview screen. For example, here’s what happens when I try to preview a newly created test app made with “fuse create app testapp”

I’m running Windows 8 64bit and Fuse (beta) release #0.5.3278. Any help would be greatly appreciated!

Thank you!

Thanks for reporting! Just to be sure, could you please do fuse --version to check that the installer worked properly? Could you please also try to right click the Fuse tray icon and shut it down?

If none of this helps, can you try rebooting your computer? In the mean time we will try to reproduce this issue here.

And just to help narrowing down the issue, have you tried previewing on Android?

Hi there, thanks for the reply! --fuse version outputs the following: Fuse version 0.5.3278

I tried again a few times after closing Fuse from the tray and making sure there were no more running Fuse processes via Task Manager, but still the same issue sadly. I also tried previewing on Android but unfortunately it also just shows a blank screen. Rebooting also does not seem to help.

Thanks for looking into it :slight_smile:

EDIT: I tried doing a clean reinstall of Fuse and it’s now working fine! I do have a new problem though; Previews don’t auto-update. I have to completely close all fuse processes then start them again to get the preview to update. I’m not touching Uno files, I’m just changing button text in the MainView.ux of the default app.

Hi, could you try to exit Fuse and post the output of fuse create app NewApp && fuse host-preview NewApp\NewApp.unoproj ?

Sorry for the late reply!

Is your computer connected to a local network? If not, this seems to be due to a newly introduced issue making local preview try to use the network for internal communication in cases where it could have used the loopback interface.

As far as I can tell, my laptop is only connected to my University’s wifi and is my internal IP address on the wifi network. Is there any more information I could provide you with that would let me know if I was connected to a local network or is there anything I can do on my end to resolve the issue?

Oh, you’re right, the 10.* range is local. It could still be that your Universty’s wifi is blocking the communication somehow though.

In the next release, preview will prioritize using the loopback interface if possible, avoiding these kinds of issues. It will also include more useful output than just a white screen :slight_smile:

For now, to figure out if this is a problem due to restrictions on your university’s network, you could try to connect to an ad-hoc network instead and see if the problem goes away.

Would trying it via a Mobile hotspot on my phone be an appropriate way to test this? Also just checking that we’re both on the same page here, the issue of Preview only showing a white screen was resolved by reinstalling Fuse, the present issue at hand is that the Preview isn’t automatically adjusting to changes made to the UX code. In order for changes to show in the preview I have to completely restart all instances of Fuse on my computer. Also thanks again for all the help and replies!

If i were to debug network issues i would rather have created an ad-hoc network on the laptop. But since it works fine the first time you open preview after exiting Fuse then it’s not very likely to be caused by network issues.

This could be a problem with file watching, could you verify that “Date modified” on the ux file you are editing gets updated when you save the file?

We’re looking into other possible issues that could cause auto-referesh to stop working.

Date modified does indeed change in File Explorer after the .ux file is saved.

That’s good at least :slight_smile:

While we haven’t managed to reproduce this issue yet, it seems that one of the DLLs shipped with the previous release contains some errors that could cause this behavior. We’re working on fixing this.

So I’ve been mainly messing around in Sublime Text then checking changes by completely restarting Fuse, but just then I decided to check if it would auto-update again. It turns out that if I mash Ctrl+S repeatedly a whole bunch of times in quick succession, then the preview auto-updates. If I just press Ctrl+S once and save the file, or if I try saving it every now and then, then I get no auto-update, but if I mash the keys really fast a whole bunch of times, the preview updates. So yeah it’s mostly functional right now which is wonderful and definitely a step up from having to restart Fuse all the time. Thanks for all the assistance and sorry for the trouble!

Hello again, and sorry for the wait. We’ve gotten some new clues in this case and have a few more questions:

First of all, does this problem still occur with the latest version of Fuse?

Second, is your project saved in a cloud folder such as Dropbox? Also, on which drives do you have your Windows installation, Fuse installation and this project?

Hi Anders, Auto-Update actually works perfectly as expected on the latest version of Fuse. It refreshes with a single save, no need to mash the button anymore. Thanks so much for the fix :slight_smile:

Great to hear Jono! And thanks for reporting back to us! :slight_smile: