Fuse does not launch with this message (fuse: Couldn't start a background process of the daemon)

Hi, could anyone help me with this problem?

I installed the latest version of Fuse with the installaiton guide, but the fuse app did not launch.

When I entered “fuse” on terminal, it gave me this error message,

“fuse: Couldn’t start a background process of the daemon”

Please let me know how to solve this problem.

Thank you.

I am having the same problem. But I actually was able to run fuse earlier. It just stopped working after doing some preview tests on an newly created project

Sorry about this, it seems to be caused by a zombie process which lingers around.

The problem should go away with a reboot but for a slightly more refined approach you can try this:

  • On OSX : lsof -i tcp:12122 -t | xargs -I {} kill -9 {}
  • On Windows : Open the task manager and force shutdown of all “Fuse” processes

No worries, thanks for the repsone I will try your solution if it happens again.

Hi, thank you for the solution, but it didn’t work.
After I use the command you gave, I could see the message

Trying to start the daemon as a background process.
A daemon background process was successfully started.

However, nothing happend afterwards.
I have tried rebooting and re-installing but nothing worked.

Is there any other solution?

Are you getting a tray icon like this?


Oh, I see the tray icon. Thank you for the help, problem is solved!

I am new to fuse and it is not common for me to use without dedicated editer.

Now it is time for me to explore tutorial and API documents


We are making some changes to the first-run experience of Fuse to make it clear how it works, and completely sympatize you on the misunderstanding. :slight_smile: Read Andreas’ post on it here: https://www.fusetools.com/developers/forums/general/fuse_beta_release_053127?page=1#post-8818f3d2-8565-4c19-a85f-89da236e270f