Fuse won't start or open a project. (Mac OS X, El Capitan)


I have reinstalled it twice, but is still stuck on the loading screen. Mono installed, sublime text installed. latest build. What can be the problem?

Hey, are you running mono 4.2.x (mono --version)? If you are please install the normal MDK: http://download.mono-project.com/archive/4.0.4/macos-10-x86/MonoFramework-MDK-

It should work on El Capitan, despite what the mono download page says.

Already did it. The problem is the same. Nothing has changed :confused: Nor monitor and inspector are not working. These utilities are crashing without opening their window.

Just for references… I tried to use Mono 4.2.x for Mac El Captain. Fuse is opening well but my project failed to launch with some weird memory error. Replaced with Mono 4.0.4. Working great so far.

toltesydavid@gmail.com: Oh I see, could you run fuse daemon -d from terminal, and post your result?

vicker@gmail.com: Good to hear :slight_smile:

Working on MacBook and having the same issue as toltesydavid@gmail.com.

Same problem and I just did the “fuse daemon -d” and this is waht I got “Already running at port 12122”

Just updated the app, but the problem is still not solved :confused:

“fuse daemon -d” command is giging back the “Already running at port 12122” answer.

Unistalled the latest mono and replaced it with the 4.0.4 version, but still not working. :confused:

Hey David, when you say “monitor and inspector are not working”, can you confirm that monitor does not work when running fuse monitor from terminal?

We are sorry about your problems, we have raised an issue.

However could you try to use our terminal commands instead. For example fuse create app MyProject to create a project. And use fuse preview to preview your project, as explained in the following tutorial: https://www.fusetools.com/community/guides/tutorial

If this doesn´t work, could you please run lsof -i tcp:12122, and look for the pid that is bound to listening at that port. Use kill [ThisPid] and replace [ThisPid] with the pid you found, to kill the daemon. After that try to use the fuse commands that was mentioned above.


Got the same issue. Downloaded Mono 4.04.4 but problem the same, just sits there on the front screen with the recent projects whirlygig.

Hey Nick, can you confirm that the Inspector and Monitor buttons fail from the dashboard as well? And if so, that fuse monitor from the terminal also fails?

Emil the kill [ThisPid] solved the problem! Now Fuse can open up new windows. (Monitor, preview etc) Thanks! :wink:

David, glad to hear it worked out for you, and thanks for reporting! :slight_smile:

I am interested to know if you tried fuse with mono 4.2.x first?

My theory is that our daemon was still running after you downgraded to mono 4.0.x. I was able to reproduce your issue, by assuming the daemon was not killed inbetween the downgrade. The daemon and most of our other mono based apps have troubles with mono 4.2.x. For your information, our monitor and inspector are also mono based applications, while tray application and dashboard are not.

Also did you try to quit our daemon using our tray icon? There should be an button called Quitin the tray icon. The effect of using that button should be similar to the lsof -i tcp:12122 trick.

I installed the latest version of Mono (for El Capitan). Than uninstalled it from terminal and replaced it with the 4.0.4. Now it is working with the 4.0.4. And yes, I quit the app with the “normal” process but nothing happend. I was going to restart my Macbook but than I read your comment and this solution finally worked. There are no other frameworks installed on my computer because this is a few days old Macbook air with clean install of the latest Mac OS X.

David, thank you for your response, it helps us a lot :slight_smile: We will keep doing our best to make the setup experience as smooth as possible.

I think I am getting a similar issue. I installed 4.0.4 and the most recent Fuse app and the dashboard refuses to launch. I can build projects in Terminal and verify they are indeed creating project folders. But there is no system tray icon though I see Fuse as well as fuse tray running in my Activity monitor. Fuse tray is not using any memory though.

I am running 10.9.5 Macbook Pro Retina.

Hi Elliot,

We are having some issues with OS X 10.9 that we have to investigate. Currently the only officially supported versions are 10.10 and 10.11. I’ll check the plans for when we plan to support 10.9 and get back to you.