Fuse disappears on reboot

I am new to Fuse and the community. I hope that someone can please help me with this issue.

Every time I reboot my computer, Fuse disappears and I have to reinstall it.

Background: I downloaded and installed Fuse last week on a computer running Windows 8.1, but when I realized that I forgot to install as Administrator, I reinstalled as Administrator without an uninstall, thinking that Fuse would automatically uninstall.

When I rebooted my computer, Fuse was completely gone:


I reinstalled again as administrator. I then updated my operating system (which rebooted my computer), and after the update, the Fuse dashboard was still there, but the rest of Fuse was gone.

This time, I uninstalled and reinstalled Fuse. Since then, I have rebooted my computer a few times, and every time, the dashboard remains but Fuse is gone and I have to reinstall it. Other than than, it seems to work fine once installed.

Thanks in advance!

Hi, do you have any anti-virus software installed?

Yes. I had disabled it for the first install, but not subsequent ones…

Which software are you using?

ESET NOD32 Antivirus version 9.0.381

Hi Emil,

I tried installing the new Fuse update, version 0.27.1, with my antivirus deactivated to see if that would resolve the problem. Unfortunately, I am still having the same problem. When I rebooted after the 0.27.1 install, not even the dashboard remained. Everything was gone. Shortcuts remained with dead links. Shell gone, everything.

Is there a way that you can resolve the issue?

Thanks in advance!

This doesn’t really sound like it’s related to Fuse to be honest (though it could be). Just to clarify: you have a user with administrator rights, and you’re not running Fuse on a company computer that might be part of any sort of reset/auto re-imaging happening on reboot? I’ve seen Windows-installations that reset to a certain state (or restore point) upon reboot. It kinda sounds like that’s what might be happening here.

It might also be too late to disable your anti-virus after you’ve rebooted. If the first paragraph in this reply doesn’t apply to you, can you please try the following (just to completely eliminate the possibility that your anti-virus is interfering with the install process):

  • Completely uninstall your anti-virus software
  • Reboot
  • Install Fuse
  • Try to run Fuse
  • Reboot

Has Fuse disappeared in the same way as before? If not: consider installing a different anti-virus, such as Microsoft Security Essentials / Microsoft Defender (depending on which Windows-version you’re on).

Hi Bent,

Thanks for your suggestions. I didn’t reply right away, because I was considering getting an Apple computer, but after the really disappointing keynote and realizing the direction they are going in, I have decided to stick with Windows 8.1 for now.

I tried all the steps that you suggested, but I am still having the same issue. By this point, I’m pretty sure the problem is not with my antivirus software. I think it’s either with Fuse and/or my operating system. Is there anything that I can do so that I don’t have to reinstall Fuse every time I reboot? I.e. any stone still left “unturned”?


Hi Angela,

I just wanted to let you know we’ve created an internal issue for us to look into this problem, but haven’t been able to fix it yet. I’m afraid there is no known workaround either.

Have you tried the latest Fuse 0.30, and if so, is the issue still there?

Can you please have a look inside <user directory>\AppData\Local\Fusetools\Fuse\ (where <user directory> is typically C:\Users\<your username>), and see which files exactly are disappearing?

Hi Anders,

I tried installing version 0.30, but the issue remains :frowning:

After restarting my computer, the directory that is missing is the Bin directory, i.e. <user directory>\AppData\Local\Fusetools\Fuse\App\Bin.

The missing Bin files are:

  • Fuse.config
  • Fuse.exe
  • uno.config
  • uno.exe

There’s something else that seems really weird to me. I took screenshots of the directory after I installed 0.30. It contains the directory <user directory>\AppData\Local\Fusetools\Fuse\App\app-

After I restarted my computer, it was replaced with an older version: <user directory>\AppData\Local\Fusetools\Fuse\App\app-

I uninstalled 0.27 using Program Manager before installing the new 0.30. I don’t know if System Restore might be an issue? I thought I had it turned off, but when I saw this strange behavior, I checked it out and it’s been creating restore points for the past month. I haven’t personally restored any points, and I have now disabled it.



Hi Angela,

Thanks for looking into this in so much detail! Have you tried rebooting after turning off System Restore, and if so, do you still have this issue?

Hi Anders,

Yes, after turning off system restore, I still have this issue.

The last time I tried restarting after installing Fuse, I decided to watch the directory. As soon as I saw my desktop, I opened the directory in Windows Explorer, and all was well.

My computer takes a long time to boot. Basically, at around 6:42 PM I saw the app- and Bin directories. But 10 minutes later, at 6:52 PM, directories started disappearing before my eyes! Then Windows Explorer went up to the parent directory by itself. Totally weird. When I clicked into the App directory, Bin and app- were gone and version 2.7 was there instead.

I noticed that both before and after uninstall/reinstall, there are a lot of registry keys for all three versions (I started with version 2.6). Could the problem lie there?

My computer has had impaired performance in general for some time now, where it freezes up and hangs. So I am reluctantly preparing to do a factory reset. Perhaps, if I do, and install the latest version of Fuse, I will not have this issue anymore.

That being said, if you figure out what is causing this problem and/or come up with a solution, please let me know.

Thanks again for your support.

Hi Angela,

At this point I’m afraid I don’t know what else to try than a factory reset as you suggest. If you decide to do that, please let us know how it went.

We are still tracking this issue, so if we find out anything more, we’ll post in this thread.

Hi Anders,

I finally got a new computer, downloaded the most recent version of Fuse, installed it, only to find the same issue happening once again! I don’t understand why this is happening. Is this an issue for other users as well?

To reiterate, I ran fuse_win_0_35_0_10867 as administrator, installed Fuse, ran through the Dashboard setup, installed the plugin for Sublime Text 3, rebooted, and checked if Fuse was still there. It was, and I was able to use an example as a test and preview it from the dashboard.

However, when I used a terminal to launch the preview it didn’t work, regardless of which terminal I tried.

I then checked the system variable and found an error. Fuse had used two semicolons to separate it from the previous variable. I removed the extra semicolon, but the variable still didn’t work. Then I tried to look in the folder which the system variable points to, the bin folder but it was not there. Why is the bin folder missing?

I think I’ve really done all that I can. I hope that on your end, you and your team will resolve the issue.


I just realized that I did not turn off my antivirus when installing Fuse. I simply followed the directions in your online documentation. If this is what is causing the issue, you should update your documents to reflect this…

I think the problem might be solved now… I deactivated my antivirus, uninstalled Fuse, reinstalled Fuse, and rebooted several times. The first few times, the problem seemed to recur, but for some reason, the problem seems to have gone away. The bin file is still there on reboot.

Perhaps I did not disable the right functionality in my antivirus the first times that I tried. Unfortunately, there is no elegant or simple way to even temporarily disable all of ESET’s functionality (there is a button that appears to accomplish this, but it does not). I had to go in and switch things off one by one. Perhaps the other times I tried, I had missed the right switch :frowning:

Anyhoo, thanks for your feedback throughout this thread. Hopefully, I will now be able to pick up some speed using Fuse!

I’m glad you got Fuse to work in the end, but of course it should be a lot simpler than this.

I emailed ESET about this issue back in December, as other anti virus vendors don’t have this issue. I never heard back from them however, so I’ve tried emailing them again now.

Thanks Anders. If you hear anything back this time, please let me know.

Hi. I have absolutely the same situation on my Windows 10 and Fuse 0.35, but I do not have and never had any antivirus software (including Eset), except for the built-in defender of Windows 10. The defender’s log does not contain any records about the deleting Fuse files, so the problem seems to me all the same with Fuse itself.

After rebooting bin directory ("\AppData\Local\Fusetools\Fuse\App\Bin") disappears, But there is a “\AppData\Local\Fusetools\Fuse\App\app-” directory which contains fuse.exe and other files.

So it seems that I found the reason for the mysterious disappearance of the bin folder. The problem was with autostart “C:\ ProgramData\SquirrelMachineInstalls\Fuse.exe” with the “–checkInstall” argument. I checked several times by running “C:\ ProgramData\SquirrelMachineInstalls\Fuse.exe” with the “–checkInstall” argument and without it, with installed Fuse. The execution of "“C:\ ProgramData\SquirrelMachineInstalls\Fuse.exe --checkInstall” causes the bin folder to be deleted. Apparently this is some kind of rare situation, since there are no mass reports, but it seems to me worth checking what exactly does “–checkInstall”

Hi Werton,

Thank you for sharing the research you have done. We’ll investigate what the --checkInstall flag argument actually do, and try to keep you up to date with our findings :slight_smile: And again, we really appreciate your report.