Can't install on Win10 machine

I tried to install the Fuse app on Win10 machine and consistently got errors. Attached below is the error file.

I have the same problem with the same error.

Can you please check whether the directory C:\Users\toluw\AppData\Local\Fusetools\Fuse exists? And if not, how much of that path exists?

Also, what is the value of the %LOCALAPPDATA% environment variable? (You can do echo %LOCALAPPDATA% in a command line to find this)

Syed, please try the same, but substitute the path above with the one in your log.

Anders, the directory C:\Users\Syed Nizar\AppData\Local\Fusetools\Fuse\App\packages exists but there is no RELEASE file.

On echo %LOCALAPPDATA%, I ran it on command prompt

C:\Users\Syed Nizar>echo %LOCALAPPDATA%

C:\Users\Syed Nizar\AppData\Local

Syed, can you please upload the log file?

Here it is.

Hi, could you please delete C:\Users\Syed Nizar\AppData\Local\Fusetools\Fuse\App\, and then rerun the installer

Already did that, still not working. Attached is the latest log.

Do you run the installer in elevated mode (eg. with adminstrator rights)?

That does the trick. Thanks for helping. Have a nice day everyone!