App crushed on only Android

My project worked well at version around 1.2.0 (I can’t remember exactly)

After upgrading fuse to 1.4.0/1.5.0 , My app can be built, and but crushed on only Android (work well on iOS) with exactly same code that worked well at 1.2.0.

Moreover, the app built with this code isn’t working on Android 8.0 Oreo.

This is my project, can you check for me please?

Do you get any error messages in Terminal if you launch the app from it using fuse preview -tandroid or fuse build -tandroid -r?

I tried testing your project, but it caused my Fuse install to die completely and I already logged an internal ticket about that. Unfortunately this prevents me from testing your project on device.

This is error message

➜  SantaVoca git:(master) ✗ fuse build -tandroid SantaVoca.unoproj -r --force --trace

Uno 1.4.3 (build 6115) macOS 10.13 x86_64 83d8656

 (0.5 s)
Compiling syntax tree
 (1.5 s)
Generating code and data
 (5.0 s)
Building Android app
 (7.9 s)

Build completed in 14.83 seconds


Installing APK on 2 device(s)Failed to install SantaVoca.apk: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]

ERROR: Process has exited, so the requested information is not available. (pass --trace for stack trace)

ERROR: Android run failed. (pass --trace for stack trace)

Stack trace (System.Exception):
  System.Void Uno.Build.BuildResult.Run(Uno.Logging.Log log) in (0.0)
  Uno.Build.BuildResult Uno.CLI.Projects.BuildCommand.Build(BuildArguments args) in (0.0)
  System.Void Uno.CLI.Projects.BuildCommand.Execute(System.Collections.Generic.IEnumerable`1[[System.String, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]] args) in (0.0)
  System.Void Uno.CLI.Program.Execute(System.Collections.Generic.IEnumerable`1[[System.String, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]] args) in (0.0)
  System.Int32 Uno.CLI.Program.Main(System.String[] args) in (0.0)

What you have there does not look like the cause of the crash you reported earlier.

This is about the app not being able to be deployed to the device in the first place. See this: