Error building for Android

Hi guys,

I’m getting this error when I try to build my app for Android.
I’m using Google Analytics Package so I’m running the following command

fuse build -t=android -DGRADLE -run

I get this error

Uno 1.1.3 (build 5510) macOS 10.12 i386 933ea5b
Configuring (1.2 s)
Compiling syntax tree (3.1 s)
Generating code and data (8.6 s)
Building Android app
2/2: fuse-tim-phone-employee.apk
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring project ':app'.
> The 'java' plugin has been applied, but it is not compatible with the Android plugins.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
## 2/2: fuse-tim-phone-employee.apk
Defining custom 'clean' task when using the standard Gradle lifecycle plugins has been deprecated and is scheduled to be removed in Gradle 3.0
Total time: 3.1 secs
(unknown): E0200: Android build failed
(3.7 s)
Build completed in 16.61 seconds
    1 error
fuse: Errors were encountered while building the project

I already did a uno clean and a fuse install android.

Can anyone help me find out what is wrong?

Thanks in advance.

Which Fuse version are you on? Passing -DGRADLE is not necessary on the latest Fuse, since Android builds are by default made using Gradle for a good while now.

What happens if you run fuse build -t=android -run?

Hi Uldis,

I’m using Fuse version 1.1.1 (build 13893).

I’ve tried that too. I tested on another computer with same OS and it worked well. Is anything that can cause this in specific computers?

Well the best we see is that error message:

The 'java' plugin has been applied, but it is not compatible with the Android plugins.

If you have access to a similar system that builds the project fine, I’d check the versions of Java, Android packages etc. That should be a good starting point.