Cannot build application on OSX

I updated Fuse Tool at yesterday (8/6, Thur, Korea) Then I cannot build my application by Fuse. And I got message, “Unfortunately, TodoApp has stopped.” This is the message I build the sample TodoApp

Fuse Version - 0.5.3309 , Updated 8/3

Thank U


Thanks for reporting this. We need a little bit more info to help debug what’s wrong.

With your phone connected, start in your project folder, then go:

cd .build
cd Android-Debug

This will open the logcat view for your app.

Then go into your project folder in a different terminal and type

uno build --target=Android --run -DCPPSTACKTRACE

When the app runs and crashes now, the log window should contain some information to help us debug this.

I typed the “uno build --target=Android --run -DCPPSTACKTRACE” But, the app is still crashed

Do you want this screenshot? If you want other, reply to me


Unfortunately the screenshot does not include the actual crash info. That stack trace there is unrelated. Please copy as much of the log as possible.

Alternatively, you can send the entire project to us for debugging.

Thanks a lot for your help! :slight_smile:


This is all of the screenshot after going the command “uno build --target=Android --run -DCPPSTACKTRACE” in TodoApp Project Directory

And these are screenshots about the sample project Todo App provided on fuse website. I just build it …

Thank you :slight_smile:


Unfortunately, there is still not enough info here. Does this only happen with this app, or with all apps you try?

What sort of device are you testing on?

Hi This happen with all apps I tried. My Device is only LG G4, Google nexus5.

Thanks for providing this information. I’ve raised an internal issue, and we will be investigating this ASAP!

Hi :slight_smile:

I solved my problem (?) I made new project and copy the sources. Then application run very well. The stopped application is built before update.

Thank you :slight_smile:

This sounds a little like you have an old build cache.

Uno generates some metainfo about which compiler made the cache etc. so that it can clean up old things when versions change. It might be that something failed here.

Can you try to run a “fuse build --clean” on the example projects that failed earlier and let us know how that goes?