xcode: same old ubase/config.h not found error as others have had


  1. On Windows 10:
  2. Create new app using fuse UI, chose “example” app (the animated square thingie)
  3. Did fuse build -t=ios
  4. Opened up folder on mac via connected share, clicked .xcodeproj project to open in xcode
  5. Play/build
  6. Meh.


Lexical or Preprocessor Issue > ‘uBase/Config.h’ file not found _config.h


I see claims that this was fixed in 0.12.4 (https://www.fusetools.com/community/forums/general/fuse_beta_release_0124) and others had problems with it also (https://www.fusetools.com/community/forums/bug_reports/getting_an_ubaseconfigh_file_not_found and https://www.fusetools.com/community/forums/bug_reports/build_my_fuse_app_report_this_issue) but:

fuse --version = 0.25.5 (build 7677) on windows 10

Mac OSX is 10.11.6 - see http://imgur.com/a/8zYYH

xcode is fresh install from app store yesterday - 8.0 (8A218a)

Yes, I’ve tried “uno clean” and I’ve also tried copying all files to the local Mac harddrive…

Halp? :frowning:

Hey Rune!

Thanks for the detailed report.

Does it work if you create or copy the app to the Mac harddrive, uno clean, and uno build again? I don’t think the Fuse build products (i.e. the Xcode project in this case) are portable across different operating systems since they use installation-specific paths to headers and libraries.

If I remember correctly the old issue was due to a problem with how Fuse detects when it needs to download its dependencies. If my hunch is right, this is not the same problem even though the error is the same.

Let us know if the above helps! :slight_smile:


I assumed that since I can’t compile with Xcode on my Windows machine anyway (since there’s no Xcode to build with) then I should be able to uno build there and just Xcode build on the Mac… but I see what you mean :slight_smile:

But ok, I will try to install Fuse on the Mac and see where that gets me - thanks!