Getting an uBase/config.h file not found


I’ve been getting this error saying ‘uBase/config.h’ file not found on Xcode. This is my first time testing the app on an actual device. Help? I tried clean the project and build after but still prompted me the error.

Xcode version: 7.3 (Latest Build) from the App Store.

Here’s the screenshot.

Thank you!

Hi Khairul,

Sorry that this isnt playing nice for you. I think Fuse may have had an issue pulling some of the dependencies. There are two ways of dealing with this, a more technical and fiddly way, and the simple way (which I would do) which is just to reinstall Fuse. A bit of a pain but will cover a few bases at once.

I’m 99% sure this is not an XCode thing as I saw it once on v6.something. Thanks for providing those details though, it is super helpful.

Please let me know how this goes for you, and again sorry that the initial experience wasnt up to scratch.

This issue is fixed in Fuse 0.12.4

It seems that is not fixed yet, i have 0.12.4 and still have error.

That is strange. Can you please try to do uno clean, and then build again?

Still getting this error. I’ve tried uninstalling fuse, updating Xcode etc… I am using buddybuild and happens on buddybuild. I had it fixed at some point but not sure what I did to get it going.

Is it possible that the 1.0.1 release re-introduced this bug?
Here is the output:

32 » In file included from include/Uno/Uno.h:4:

33 » In file included from build/iOS/Preview/include/Uno.h:3:

34 » In file included from include/Uno/ObjectModel.h:8:

35 » In file included from include/Uno/Memory.h:5:

36 ✗ include/Uno/_config.h:7:10: fatal error: ‘uBase/Config.h’ file not found

37 » #include <uBase/Config.h>

38 » ^


40 The following build commands failed:

Please don’t try to hijack old threads and instead post new ones with all the relevant details.