Unable to find application named 'Xcode'

I installed Xcode Version 9.0 beta 3 (9M174d) and did a Swift “Hello, World” app and got it to run on my iPhone 6S Plus.

In Fuse, I did Preview > Preview on iOS and got this:

I did notice there is no Xcode in the Applications folder on my MacBook Pro… is that the problem? I’m a Windows guy and I have no idea how to debug this. I really want to try the preview feature before my Fuse Pro trial ends in three days.

I tried this:

But there and found the /Users/Pete/Developer folder but there is no Applications folder under that in which to create the alias per the StackOverflow solution.

Hi Peter,

some googling hints that you might need to install “XCode developer tools”. I found a guide that seems somewhat related on this page. Hope this helps.

As for try the preview feature - it works without an active pro subscription, so no worries.

Thanks, I’ll look into that next to dig deeper, even though I (supposedly) already installed them because the dialog box popped-up and asked me to.

fuse build --target=iOS --run

I believe the main problem is still this:

no developer tools were found at '/Applications/Xcode.app

which is true… that file doesn’t exist… Xcode is installed somewhere else and that file doesn’t seem to exist anywhere on my file system.

Alright, then you’ll need to figure out how to properly install XCode first. Unfortunately I don’t have any particular advice on that.

Solved! thank you Yes, I never actually installed Xcode (which doesn’t make any sense to me since I’ve been using it).