Unable to build on iOS

An error is generated when compiling it to run. I can get the code to deploy and run via removing the weak reference, however a memory warnning occurs due to the referencing counting most liekly.

/Users//Documents/my_first_project/build/iOS/Preview/src/UIResponder+FirstResponder.mm:4:8: Cannot create __weak reference in file using manual reference counting

“static __weak id currentFirstResponder;”

Please let me know if there is another way to resolve this or it is a bug that needs to worked on.

I am working on OS X 10.9.3 with the latest FuseTools and Mono Runtime.


Thanks for repoting.

Can you please provide a test case (upload zip with a project) that reproduces this errror?

I’m having the same error with just the default new template.

What version of Xcode are you using?

We’ve reproduced this with the Xcode 7.3 beta, and have raised an internal issue to get it fixed as soon as possible. In the meantime you can downgrade to Xcode 7.2 where it should still compile.

Thanks for your report!

7.3 is no longer in beta and is the latest release. Your example templates no longer build.

Same problem here after I updated Xcode, hope you get this fixed soon.

It’s already fixed. Make sure you are on build 6183 and make sure you ran “uno clean”.

Ok, great, I just need to get the newest build, thanks!