Trying to uninstall existing version of APK

When i’m gonna preview my build in Andriod…after a while this line shows and nothing else happens???file

Are you sure your device is plugged in via USB? Does it show up if you do adb devices?

but i can’t see my preview in andriod alos…when i’m gonna do that it says Trying to uninstall existing version of APK and then stucks

Hi, could you please try to type %programdata%\uno\SDKs\androidsdk\platform-tools\adb devices on the command line and then send us the output from there?

(This is basically the same as Knatten said, but this version will work even if you don’t have any other Android SDKs installed)

The problem you’re seeing means that fuse & adb is unable to connect to your Android device. The normal reasons for that error are usually:

  • There’s something wrong with the USB cable between the computer and the device
  • You might be missing the USB driver for this specific Android device.

Here’s the screenshot file

Ok, since adb does not show any devices this means that there is a problem with the USB connection to the phone.

The following instructions, taken from the Android developer documentation (, should get this fixed:

Enable USB debugging on your device.

On most devices running Android 3.2 or older, you can find the option under Settings > Applications > Development. On Android 4.0 and newer, it’s in Settings > Developer options. Note: On Android 4.2 and newer, Developer options is hidden by default. To make it available, go to Settings > About phone and tap Build number seven times. Return to the previous screen to find Developer options.

Set up your system to detect your device.

If you’re developing on Windows, you need to install a USB driver for adb. For an installation guide and links to OEM drivers, see the OEM USB Drivers document :

If there are still problems after doing this then it might be a good idea to try a different USB cable.

I have a mirror problem. But i dont on problem cable or driver. Becouse I run %programdata%\uno\SDKs\androidsdk\platform-tools\adb devices commmand promt and then output. And i am install samsung usb driver but not working.

file file

and sublime text editor run preview mode i have some error but not working

Can you please try to run fuse preview --target=Android from the command line, and paste the log?

I have this:

Seems no there problems, but in my device only displays “Failed to connect”. Already installed driver and test with adb, works fine.

@davidcort: In your case it seems like build / export works just as it should. It sounds like the issue you’re experiencing is instead related to the wifi connection between the device preview and your development computer.

Have you made sure they are both connected to the same wifi, as described here: ?

@murat.atalay: The problem you experienced here was a different one (not related to the connection between device and computer). We had an issue where anyone with a Turkish locale on their dev computer would get issues like this.

We have fixed this internally and the patch will be included in an upcoming release.

hello, everything seems to work fine during the build and installaton of apk. but when the connection tries to be established on my device, after a while, all i get is failed to connect. i am making use of the same wifi connection for both my system and the device. i tried to even change the ip address to that of the system but i still get the failed to connect message.

how can i sort this please? are you on Windows or OS X? Do you have a firewall that you could disable?

hi I’ve problem about my first code.
I tried to show on android but my application didn’t work on my android device (htc flyer android version working on 3,2.1)
does anybody know which version of supported by fuse tools or why my code doesn’t work by successfully I’m showing shortcut on my device and have seen "setup success " word on console. anyway does anybody help me :slight_smile: pls

ayarhasan: Fuse officially supports Android 4.1.x and upwards. While something slightly earlier (like 4.0.x) might work we don’t do any testing or make any guarantees for OS versions older than that.

However, it would still be interesting to know how your app crashes / misbehaves.