Sublime Plugin: no autocomplete on tags / classes, only on attributes?

Fuse: 0.9.4 (5388) Sublime: Stable 3083 - unregistered

Hi all.

I try to get my hands on Fuse and installed Fuse and Sublime text, but I can’t get autocomplete to work (it’s not about beeing lazy, it’s also very helpfull when you start to learn something new). Sometimes it works (only once), and it does not work when I use (tried a couple of things).

However, on attributes the autocomplete seems to work most of the times. It’s a bit wierd. I reinstalled evertything and then it worked on a example, then I moved to my test (simple Hello World) and it stopped working at all.

No error output on the console.

Typical picture: file

Sometimes: file

or this… file

But this works: file

Any ideas?

Hi, this is due to a limitation in the code completion. We don’t suggest the <App> tag itself, nor do we provide suggestions directly inside its scope. So you get

<App Theme="Basic">
  <!-- completion here and inwards -->
 <!-- No completion here -->

I’ve created an issue to improve this.

Just to confirm that you’re not seeing any additional bugs, can you please verify that you get code completion inside the <StackPanel> in the code above?

Thanks, Anders. While completing some tutorials from YouTube, I realized that the auto complete works from the third level, i.e. from the Panels as you already mentioned.

So yes, I can confirm: Everything in the StackPanel has Autocomplete / suggest. I am pretty sure that suggesting <App> adds no value, but the second level would make sense, especially as some tutorials start from the second level.

(I am not sure, but I thought seeing auto complete / suggest on the second level from the tutorial vids, but can’t remember right now)

Ok good, then at least we’re seeing consistent behaviour! :slight_smile: I agree that the second level makes sense, so we’re going to fix that.

So, is it possible without StackPanel tag? Because according the video that I watch, this is possible but, my sublime text can not work if not inside the StackPanel

The App can only have one Element inside it. So it’s like a special Panel with only one position.