Stack Trace command

New to Fuse. I downloaded a project from a friend’s BitBucket and getting an error when i do preview.

I get this message: “FATAL ERROR: Failed to load project because of missing files (pass --trace for stack trace)”.

How do i pass trace? i tried “fuse preview --trace” and other combinations without success.

Thanks in advance !


Passing --trace probably won’t do you much good in this case. If you could share the project that would be the fastest way to a resolution.

Otherwise, you can try to open Terminal/CMD, open the project root folder and execute uno build -vv command. It should throw some useful information there.

Hope this helps!

Thanks UIdis. With “uno build -vv” I am getting this error:

in my unoproject i have:

in my MainView.js i have:

and in my MainView.ux:

i followed what the package creator suggested in GutHub:

and i installed the package using fusepm:


Not sure what i am doing wrong.
Thanks in advance !

I think you can just get rid of the line <ModalJS ux:Global="Modal" /> and the project should be working alright. The require() in JS should be enough for the modals to work.

Thanks Uldis. That worked perfectly. Much appreciated.