Fuse Community

PushNotification inoperative on Android 8 and above

Hello.

I am currently using 1.12.0 version using fuse-sdk.

Everything’s working fine.
PushNotification does not work on Android 8 or higher devices.

I checked the fuselibs file in the local area and it seems that it is not working because it does not set the notification channel.

Is there a solution to this problem?

Hey @Haruka, the required notification channel since Android 8+ was catered for in this PR: https://github.com/fuse-open/fuselibs/pull/1220

Here’s the docs for the new features: https://github.com/rbtech/fuselibs/blob/21358bcf6a574f8becdcdaa91666a850c4dac6ec/Source/Fuse.PushNotifications/Docs/Guide.md#additional-android-push-notification-features

Thank you for your answer.

As the setting of the link you sent.
To the file unoproj

Notification channel
Nofitication channel group.
Notification channel importance.
Notification channel lock screen visibility.
Notification channel light color.
Notification channel sound.
Notification channel vibration.
Notification channel show badge.
Notification badge number.
Notification badge icon type.
Not be be to set the value of the notification channel, even if OK.

Can’t I use npm install fuse-sdk?

The PR got merged on 30 Jul 2019: https://github.com/fuse-open/fuselibs/commits/master

Not sure if fuse-sdk has the latest from fuselibs but if it does, then you should have the notification channel without setting anything (it sets a default channel).

If you don’t have that happening, then the PR probably didn’t make it to the fuse-sdk yet, in which case, you need to compile with the latest fuselibs repo, instead of the one from the fuse-sdk.

You can simply add a “.unoconfig” file to the root of your project with the line:

Packages.SourcePaths += [path to your local repo]/fuselibs/Source

Then run “uno doctor” to make sure it compiles with the fuselibs source you’re pointing to.

I’m sorry to keep asking questions.

At the project root.Create an unoproj file.
Package.Source Path “D:/Fuse-Sdk/fusels/Source”

After adding the line, the “uno docor” command was executed on the project root.

The results below were obtained after the run.

Where did I miss?

No problemo, your Uno used is the old version (1.9.0), you need to use 1.10 and above.

I’ve solved it!
Thank you very much.:laughing:

1 Like