Issue with using Firebase and building to iOS

So, I have been using the Fuse.Firebase library on github for about a year now and usually had no problems. I ran into one the past couple days that I am completely stumped. It was building to iOS just fine, but I had changed a couple things a ran an uno clean, then re-ran the build (I tried 3 different ones, (fuse build -tiOS -DCOCOAPODS, fuse build -tiOS -DCOCOAPODS -d, fuse build -tiOS -DCOCOAPODS -vv), and they are all giving me the same error essentially.

/Users/hahnstrong/Desktop/eskape/Eskape/build/iOS/Debug/src/ error: cannot initialize a parameter of type ‘FIRAuthDataResultCallback _Nullable’ (aka ‘void (^)(FIRAuthDataResult * _Nullable __strong, NSError * _Nullable __strong)’) with an rvalue of type 'void (^)(FIRUser __strong, NSError __strong)’
fuser, NSError
ferror) {
In file included from /Users/hahnstrong/Desktop/eskape/Eskape/build/iOS/Debug/src/
In file included from /Users/hahnstrong/Desktop/eskape/Eskape/build/iOS/Debug/Pods/Headers/Public/Firebase/Firebase.h:12:
In file included from /Users/hahnstrong/Desktop/eskape/Eskape/build/iOS/Debug/Pods/Headers/Public/FirebaseAuth/FirebaseAuth.h:21:
/Users/hahnstrong/Desktop/eskape/Eskape/build/iOS/Debug/Pods/Headers/Public/FirebaseAuth/FIRAuth.h:500:66: note: passing argument to parameter ‘completion’ here
completion:(nullable FIRAuthDataResultCallback)completion;
I went to a different one of my projects, changed some stuff and ran the build, it worked fine. I ran uno clean, then re-ran the build, and it began to fail again under this same error. Any thoughts on what might have changed? I can give you access to my repo if necessary.

Have you tried Fuse.Firebase from @Baggers :