I get this error on my Jolla with the newest version of Fuse

Could be that the android subsystem used by Jolla is too old? But it worked before I upgraded to the new version of Fusetools…

Are you using require("AsyncStorage") in JS anywhere?

parse-1.5.0.min.js contains require("AsyncStorage"). This is the same version of the Parse SDK as you use in your examples, and it’s worked fine until this upgrade!

I’ve just tested a project locally with fuse 0.5.8000, parse-1.6.3.js, and preview, and I don’t get this error. I’ll try with parse.1.5.0.js next, but I recommend you try to upgrade to a newer version of Parse as well. We will be updating the Parse version in the examples soon. In the meantime, do you get the same error in preview, or is it only on your android device?

I tried parse.1.5.0.min.js (closest I could find, but it’s the same code, only minified) and I didn’t get the error in preview, but I did get it on my android device here. Going to try with parse-1.6.3.js next.

Ok, so it works with parse-1.6.3.js. I noticed that my copy of 1.6.3 was packaged from source though; the latest available one on the website is 1.6.2.

Tested that as well on the device, and it looks like 1.6.2 has the same issue as 1.5.0, so I put my copy of 1.6.3 up on dropbox. I’d recommend using that until Parse puts out a newer official version.

I’ll also bump the priority internally for getting our example projects’ Parse versions up to date :slight_smile:

Side note; Parse has been updated in the examples already to the same version I’ve put on my dropbox (though it may take some time for the article code to update, the download links work fine): https://www.fusetools.com/developers/examples/todoparseexample

Neat! :smiley: