Fuse.View problems

So I decided to give Fuse.Views a test-drive. I’ve written about my experiences on stackoverflow-docs.


Issue 1: <ExportedViews /> not working as intended in preview/build:

<ExportedViews /> will behave as <App /> when doing normal fuse preview and
uno build

Not true. You will get this error when previewing from Fuse Studio:

 Error: Couldn't find an App tag in any of the included UX files. Have
 you forgot to include the UX file that contains the app tag?

Issue 2: When pressing the native android back button the app crashes.

If I were to run the hikr app as a normal fuse app, you could go back from the edit screen (EditHikePage.ux) back to the hikes list (HomePage.ux) by pressing the back button on android.

When I run the app as an exported view and press the back button the app crashes with the following error:

A/libc: Fatal signal 11 (SIGSEGV), code 1, fault addr 0xdeadcab1 in tid 18026 (io.fuseviewtest)
        [ 05-25 11:52:33.658 16567:16567 W/ ]
        debuggerd: handling request: pid=18026 uid=10236 gid=10236 tid=18026
>>> fuse --version
Fuse version 1.0.0 (build 13426)
Copyright (C) 2017 Fusetools

>>> system_profiler SPSoftwareDataType

    System Software Overview:

      System Version: macOS 10.12.4 (16E195)
      Kernel Version: Darwin 16.5.0
      Boot Volume: Macintosh HD
      Boot Mode: Normal
      Time since boot: 3 days 7:47

Hi Luca,

thanks for reporting! Internal tickets have been raised and you’ll get notified as soon as there’s any movement on these.


Thanks for the feedback!

Replacing <App /> with <ExportedViews /> created more problems and confusion than it solved. We have changed the design slightly, you can now use <ExportedViews /> by itself.



	<Panel ux:Class="MyComponent" />
	<Video ux:Class="MyVideo" />

		<MyComponent ux:Template="MyComponent" />
		<MyVideo ux:Template="MyVideo" />


Expect this API change in the next release

Waiting the patch :slight_smile: Is there some news about the second issue?

Second issue fixed here: https://github.com/fuse-open/fuselibs/pull/1183

1 Like