fuse install android failed.

Updated to Fuse 0.35 and my android sdk installation failing.

Perhaps it is because the SSL connection failed, so I need an option to force it to connect via HTTP. How can I adjust?

fuse install android
Fuse 0.35.0 (build 10867)
# Starting android installer
Installing platform-tools which may take a while...
Warning: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to fi
nd valid certification path to requested target
Warning: Failed to download any source lists!
Error: Failed to find package platform-tools
An error occurred during installation: Failed to install package 'platform-tools'
fuse: Failed to install android

I’m using Fuse in Windows 10 Environment.

Hi, can you please run

sdkmanager --no_https platform-tools build-tools;23.0.1 cmake;3.6.3155560 ndk-bundle platforms;android-21 platforms;android-23 extras;android;m2repository extras;google;m2repository

The sdkmanager is found by default here %localappdata%\Fusetools\Fuse\Android\AndroidSDK\tools\bin\sdkmanager.

After you have ran this command, run fuse install android again.

A fix is also scheduled for next release :slight_smile:

Good to hear fixing in next release. :smiley:

By the way, cannot run that my “Fusetools\Fuse\Android” folder only has a file “.sdkconfig” and empty.

I see, you can locate the path to the Android SDK by searching for Android.SDK.Directory in the .sdkconfig that you found.

Then run

[AndroidRoot]/tools/bin/sdkmanager --no_https "platform-tools" "build-tools;23.0.1" "cmake;3.6.3155560" "ndk-bundle" "platforms;android-21" "platforms;android-23" "extras;android;m2repository" "extras;google;m2repository"

Where [AndroidRoot] is the path to the Android SDK.

Hi guys,

I’m with the same problem, but when I try to execute the sdkmanager command I receive the follow error :

And this is the same message I receive when trying to download the android :

Any ideas on how fix that?


Hi, please add " around the packages names, eg. "platform-tools" as in my post above.

Hi Emil, I put the " as you said and apparently works, but my Java crashes right after the command runs…

The command is the same as you put above :

sdkmanager --no_https "platform-tools" "build-tools;23.0.1" "cmake;3.6.3155560" "ndk-bundle" "platforms;android-21" "platforms;android-23" "extras;android;m2repository" "extras;google;m2repository"

I’m missing something?

Which java version do you have? By default Java is installed at C:\Program Files\Java.

The JDK is : jdk1.8.0_45

And the JRE is : jre1.8.0_121

Can you try run sdkmanager --list instead?

Same problem…=/

Java crashes after I run the command…

I need update my JDK version, or something like that?

I think your JDK version and JRE version looks fine, anyways it doesn’t hurt to update JDK and JRE.

I updated my JRE yesterday, so I’ll update my JDK now and try again, hope it works…

Unfortunately…same problem =/


Cmd command

I was thinking on download a previous version of Fuse and try to download the android…

The sdkmanager you are running, and which fuse install android as well is running, is a tool released by Google. It could be that there are issues in the latest version of Java SE, which causes the sdkmanager to crash.

Anyways, you may try to extract and run tools/bin/sdkmanager --list from https://dl.google.com/android/repository/tools_r25.2.3-windows.zip to see if the problem is caused by a corrupt installation of Android SDK.

Well…if I told you that even this new version of tools throws the same error, do you believe me? =/

And if I delete the Android fold on Fuse and try to download a new version, the download stops on the same point "failed to install package ‘platform-tools’ ".

Oh, then I’m sorry, I don’t really know what else to do, than filing a bug report to Google here https://code.google.com/p/android/issues/entry?template=Developer%20bug%20report

An older version of fuse may work, since in older versions we didn’t depend on the latest things the Android SDK could provide us. The following version should work fine for example: https://www.fusetools.com/downloads/

Thanks for your patience Emil, I’ll try the older version.

Hey Emil,

Just to let you know, I finally did it! I installed the 0.34 version and the android install ran without any problem, thank you!

I hope that can this problem be fixed in the next release.