Error installing Android

I have the current SDK already installed, the Fuse installer is trying to move away or delete it then it fails. Can I just tell it to use that existing path?

Fuse should definitely not try to delete or move any other SDKs that it has not installed itself.
Can you please provide the log output you’re seeing?

This is from the command line after running “fuse install android”. It does mention that it was a target FILE, not files so I’m not sure what it was trying to delete.

Fuse 0.35.0 (build 10867)

Starting android installer

Installing platform-tools which may take a while…
Warning: An error occurred during installation: Failed to move away or delete existing target file: C:\Users\Jason\AppData\Local\Android\android-sdk\platform-tools
Move it away manually and try again…

Hi Jason,

That message is coming from the sdkmanager provided by Google, so I’m not sure which file it’s trying to delete.
Anyways, this seems to be a well-known issue, so you should try to follow but instead of extracting the, extract platform-[something].zip.

Hope it helps :slight_smile:

I fixed it with the SDK Manager, update failed there too the first time. Then I selected the platform tools individually and it worked. I ran the fuse android installer again successfully. I then ran “fuse preview -t=Android” and got the following error.

C:\Users\Jason\Documents\Fuse\first\build\Android\Preview\first\app\src\main\build.xml:90: Cannot find C:\Users\Jason\AppData\Local\Android\android-sdk\tools\ant\build.xml imported from C:\Users\Jason\Documents\Fuse\first\build\Android\Preview\first\app\src\main\build.xml

(unknown): E0200: Android build failed
?: Error E0200: Android build failed


The issue you are seeing now, can be fixed by running fuse preview -t=Android . -DGRADLE, note the . in the command. Also, a fix for this problem is scheduled for the next release.