Fuse Community

Can't build after upgrading to Uno 1.12 using NPM: license error

Due to the fact that now Google accepts only APK built with SDK 28 I decided to uninstall everything about Fuse: Android SDK & NDK, Fuse Studio 1.9 and start over with the handy npm as created by MortenD.

I installed npm and bash
then I ran npm install -g fuse-sdk and npm install -g android-build-tools .
I then checked that PATH variable %APPDATA%\npm comes before Fuse.

But when I ran uno build android myapp.unoproj or uno build android --configuration=release myapp.unoproj the process stopped reporting License not accepted and NDK missing as follows:

Warning: License for package Android SDK Build-Tools 28.0.3 not accepted.
Warning: License for package Android SDK Platform 28 not accepted.
FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':app'.
> Failed to install the following Android SDK packages as some licences have not been accepted.
     build-tools;28.0.3 Android SDK Build-Tools 28.0.3
     platforms;android-28 Android SDK Platform 28
  To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
  Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html

  Using Android SDK: C:\Fuse\tsn21\build\Android\Release

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

NDK error:

NDK is missing a "platforms" directory.
If you are using NDK, verify the ndk.dir is set to a valid NDK directory.  It is currently set to C:\Fuse\tsn21\build\Android\Release.
If you are not using NDK, unset the NDK variable from ANDROID_NDK_HOME or local.properties to remove this warning.

I altready tryied to run manually
sdkmanager "platforms;android-28"
sdkmanager "build-tools;28.0.3"
sdkmanager --licenses
in
C:\Users\User\AppData\Local\Android\sdk\tools\bin\

but it did not solve the problem.

Kindly help me solve this.