App freeze in Fuse v1.5


We recently updated Fuse from v1.4 to v1.5 and found that around 9 out of 10 builds the Fuse Preview will freeze at the screen “Loading. Starting project…” after Reifying finished. There is no exception shown in the log or problems.

We tried to fall back to v1.4, and it works perfectly.

BTW we are using macOS 10.3.2.

Hi Vicker,

have you been able to pinpoint what causes the problem? Is that only happening with one specific project, or does it also affect brand new, clean, empty projects?

Hi Uldis,

We tried to test it with a blank app, it works pretty well with both 1.4 and 1.5. We shall try other projects that we have in hand and keep you updated.

For the app that we got problem with, we tried to revert to every version within the last 2 months, the results so far is quite random in 1.5 where most builds freezes, while 1.4 is flawless.

By the way, the affected app don’t have any custom uno code.

Alright, in that case we’ll want to see the failing project. Could you share it with us somehow, or if it’s sensitive put it here?

Sure, Uldis. I just share the file to your Dropbox.

If you prefer, we can also add you to the GitHub repository directly. Just let me know which email addresses I should invite.