Unable to deploy to Android device


I’m trying out Fuse on windows 10. Local preview works but testing on the device fails. After executing fuse build tandroid, I get the log below. An app is opened on the phone. It says Connecting, ... and after sometime I get the Failed to connect page. I thought it was a firewall thing so disabled it but it was the same. What am I doing wrong?

E:\Playground\Fuse\Layout>fuse preview -t=android
Fuse 0.22.0 (build 6996)
Build started: FullCompile
Configuring (6.04s)
Compiling syntax tree (9.39s)
Generating code and data (18.14s)
Building Android app
1/2: libLayout.so
2/2: Layout.apk
    [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.

Build completed in 45.89 seconds
Build ended
Installing APK on 1 device(s)
Launching activity 'Layout'
Running logcat on 076f2129251796f2
07-22 23:28:36.132   778   788 I ActivityManager: Start proc 3312:Fuse.Preview/u0a163 for activity Fuse.Preview/.Layout
07-22 23:28:36.135  3312  3312 I art     : Late-enabling -Xcheck:jni
07-22 23:28:36.193  3312  3312 D Layout  : SUT: false  CML: false  SDK: 23
07-22 23:28:36.323  3312  3312 I Adreno-EGL: <qeglDrvAPI_eglInitialize:379>: QUALCOMM Build: 08/12/15, 70b1c55, I9e0bc0c0ce
07-22 23:28:36.507  3312  3337 D OpenGLRenderer: Use EGL_SWAP_BEHAVIOR_PRESERVED: true
07-22 23:28:36.544  3312  3312 E libEGL  : eglSwapBuffersWithDamageKHR:1089 error 300d (EGL_BAD_SURFACE)
07-22 23:28:36.554  3312  3337 I OpenGLRenderer: Initialized EGL, version 1.4
07-22 23:29:39.819  3312  3312 I Layout  : InternalError: UnhandledException: Failed to connect to simulator host: Connection timed out
07-22 23:29:39.819  3312  3312 I Layout  :  in Outracks.Simulator.GeneratedApplication<C:\ProgramData\Uno\Packages\FuseCore\0.32.11\$.uno:307>

Hi Richard,

It looks like you’ve tried a few things already, but please have a look at this list of things to try.

Hi Anders,

Thanks for the info. I checked the faq and everything appeared to be in order. Tried so many things, restarted the machine, created a new app and it worked. Not really sure what the issue was but it is working now.

Good to hear you got it to work in the end, and sorry for the trouble!