Specified cast not valid

Fuse 0.28.1 (build 8199)
OSX El Capitan 10.11.6

I have a simple test project. I have added some code to it that probably doesnt work and I want to see the error thrown to work on it.

Im getting a Javascript error that says " Specified cast is not valid". The error references line 125 in the .js file while the file only has 46 lines in it. Does this look like something anyone has seen? I tried uno clean, then rebuilt the unoproj and got the same error. Nothing in the forums.
#This is the .js file:

// var Observable = require("FuseJS/Observable");
var Backend = require("./Backend");

// var hikes = Observable();

// fetch('http://localhost:8080', {
var xhr = new XMLHttpRequest();
xhr.responseType = 'json';
xhr.open("POST", "/graphql");
xhr.setRequestHeader("Content-Type", "application/json");
xhr.setRequestHeader("Accept", "application/json");
xhr.onload = function () {
  console.log('data returned:', xhr.response);
      query: `query {
      places {
    .then(function(response) {
        // if (response.status !== true) {
        //  errorMessage.value = "Something went wrong: " + response.status;
        //  return;
        // }
        response.json().then(function(data) {

            for (var i = 0; i < 10; i++) {
                var item = data[i];
    }).catch(function(error) {
        /* Act on the event */
        errorMessage.value = "Oh no :(";

module.exports = {
    hikes: Backend.hikes,
    searchText: Backend.searchText,


#This is the error being thrown.

#Fuse Monitor Output:

LOG: Error: JavaScript error in Modules/Context line 125. Specified cast is not valid. in Fuse.Scripting.ScriptModule+RequireContext</usr/local/share/uno/Packages/Fuse.Scripting/0.39.3/$.uno:214>

I am figuring this is not expected since the error is not really saying anything(to me anyway). Any idea how to get a valid error here? In the alternative, can you explain what this means? Thank you.


This sounds like there is an error in the generated code from the UX compiler. Can you please upload a complete test project that reproduces the issue?