Run fuselibs locally

#1

Hi guys,

I’m trying to run fuselibs locally in my mac.

I’m following this tutorial on git.

My system is a MacOS High Sierra Version 10.13.4. I already have what is in the Requirements section.

If I run build.sh I get

Feeds used:
  /Users/anaalmeida/.nuget/packages/
  https://www.myget.org/F/fuse/api/v3/index.json

All packages listed in /Users/anaalmeida/Projects/fuse/fuselibs/fuselibs-master/Stuff/packages.config are already installed.
ERROR: No input files

I also create a .unoconfig file on my project directory and add the path to the fuselibs I’ve cloned.

Packages.SourcePaths += /Users/anaalmeida/Projects/fuse/fuselibs/fuselibs-master/Source

But I cannot run my app with these version of the fuselibs, it runs with the installed version.

Uno 1.7.1 (build 6568) macOS 10.13 x86_64 8b90833
Copyright © 2015-2018 Fusetools

A side note, I’m using Fuse version 1.7.3, but when building the project it shows that I’m using the version 1.7.1.

Am I missing something here or doing something wrong?

Thanks in advance

0 Likes

#2

Try moving that .unoconfig file to your home directory (i.e. /Users/anaalmeida), then run uno config in Terminal and make sure the SourcePaths entry shows up there.

Then if it does, proceed with building again. Hope this helps!

0 Likes

#3

Hi Uldis, thanks for your reply.

I’ve already done that and the outcome is the same.

When I run uno config I get:

Uno 1.7.1 (build 6568) macOS 10.13 x86_64 8b90833
Copyright © 2015-2018 Fusetools

Uno settings
Android.NDK.Directory      /Users/anaalmeida/Library/Android/sdk/ndk-bundle
Android.SDK.BuildToolsVersion (../../../../Library/Application Support/Fusetools/Fuse/Android) 25.0.2
Android.SDK.Directory      /Users/anaalmeida/Library/Android/sdk
Assemblies.Plugins         (/Applications/Fuse.app/Contents/Uno) Uno.Compiler.Extensions.dll
Assemblies.Test            (/Applications/Fuse.app/Contents/Uno) uno-test.exe
Assemblies.TestGen         (/Applications/Fuse.app/Contents/Uno) uno-test-gen.exe
Assemblies.Uno             (/Applications/Fuse.app/Contents/Uno) uno.exe
CMake                      /Users/anaalmeida/Library/Android/sdk/cmake
CommonDll                  (/Applications/Fuse.app/Contents) MonoBundle/Outracks.Common.dll
HaveAllSDKPackages         (../../../../Library/Application Support/Fusetools/Fuse/Android) true
Java.JDK.Directory         /Library/Java/JavaVirtualMachines/jdk1.8.0_40.jdk/Contents/Home
ModulesDirectory           (/Applications/Fuse.app/Contents) Modules
Mono                       /Applications/Fuse.app/Contents/Mono/bin/mono
Packages.Default           (/Applications/Fuse.app/Contents/Uno) Fuse
                           (/Applications/Fuse.app/Contents/Uno) FuseJS
Packages.Feeds             https://packages.fusetools.com/api/premium/v2
                           https://packages.fusetools.com/api/standard/v2
Packages.InstallDirectory  /Users/anaalmeida/Library/Application Support/Fusetools/Packages
Packages.LockFiles         (/Applications/Fuse.app/Contents) uno.packages
                           (/Applications/Fuse.app/Contents) unolibs.packages
                           (/Applications/Fuse.app/Contents) fuselibs.packages
                           (/Applications/Fuse.app/Contents) premiumlibs.packages
                           (/Applications/Fuse.app/Contents) Android.packages
Packages.SearchPaths       /usr/local/share/uno/Packages
                           (/Applications/Fuse.app/Contents) ../../Packages
Packages.SourcePaths       /Users/anaalmeida/Projects/fuse/fuselibs/fuselibs-master/Source
Paths.AppLoader            (/Applications/Fuse.app/Contents/Uno) .
SdkConfig                  /Users/anaalmeida/Library/Application Support/Fusetools/Fuse/Android/.sdkconfig
SystemReactiveDll          (/Applications/Fuse.app/Contents) MonoBundle/System.Reactive.dll
TemplatesDirectory         (/Applications/Fuse.app/Contents) Templates
UnoHostCommonDll           (/Applications/Fuse.app/Contents) MonoBundle/Outracks.UnoHost.Common.dll

The SourcePaths is correct:
Packages.SourcePaths /Users/anaalmeida/Projects/fuse/fuselibs/fuselibs-master/Source

When I build the application it has the some behaviour has before:

Uno 1.7.1 (build 6568) macOS 10.13 x86_64 8b90833
Copyright © 2015-2018 Fusetools


Configuring

Is every information on uno config correct to run fuselibs locally?

0 Likes

Android - Push notifications payload event not fired if there are more than 1 notifications in the list
#4

Hey @Ana_Almeida,

I literally just had a similar issue; I previously installed the libs locally, and when trying to reinstall, couldn’t get the version I wanted working, then I went hunting for all the places with the packages and found that if I cleared the following folders, I was able to recompile from the local libs again! :smile:

//Go to Finder > Go > Library [Hold left shift]
[Your user home]/Library/Application Support/Fusetools/Packages
/usr/local/share/uno/Packages

After running uno build in my project, the packages in ..Library/Application Support/Fusetools/Packages were repopulated.

I’m busy tinkering with one of the source libs and just found uno doctor, its helping me debug, hopefully I’ll come right after cleaning all the bugs but maybe the above will help ya already.

0 Likes

#5

Oh hey, I also found the command uno update via uno update --help.

0 Likes

#6

P.s. just discovered that you’ll probably want to keep these 2 packages for building a native preview:

/usr/local/share/uno/Packages/Fuse.Preview.Core

/usr/local/share/uno/Packages/Outracks.Simulator.Common.Uno

0 Likes

#7

and any solution for windows?

0 Likes

#8

Try using the latest Uno via NPM: https://github.com/fuse-open/uno

0 Likes