Oct 2018 - How to update to latest Fuselibs and Uno


#1

Tip: its a good practice to backup your older files :smiley:

  1. Download latest Fuselibs and Uno:
  1. Compile Uno
    2.1. Get the prerequisites (Mono, Bash, Make, NodeJS and NuGet - You can also get and use Visual Studio, this tut is focused on command line)
    Mac: To install NuGet - mono nuget.exe (Ref)
    2.2. Run make release from terminal/command line of the Uno folder

  2. Setup latest Fuselibs with your project
    3.1. Create a file named .unoconfig in your project folder
    3.2. Enter the path to the fuselibs in the file on the first line like so:
    Packages.SourcePaths += /github/fuselibs/Source

  3. Setup latest Uno
    You will find your compiled Uno in the release folder
    4.1. Copy uno executables(uno & uno.exe) to fuselibs/Stuff folder
    4.2. Copy lib folder to fuselibs/Stuff/lib folder
    4.3. Mac: Copy and rename the bin folder to Uno folder in the Fuse application: Fuse.app/Contents/Uno
    Win: Copy contents of bin folder into Program Files (x86)/Fuse
    4.4. Copy fuselibs/Stuff/uno.packages and override Fuse.app/Contents/uno.packages

  4. Run uno doctor in project folder to make sure your libs are up-to-date.

  5. Run/preview/export as per usual

P.s. if I’ve left anything out, just let me know.


Latest Fuselibs not loading images via url
Latest Fuselibs not loading images via url
#2

Hello! On Windows when running “make release” I get the following error:

process_begin: CreateProcess(NULL, bash -l scripts/pack.sh, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [release] Error 2

I have added uno and uno/bin to the system environment variables.


#3

Sounds like you’re missing bash. We require msys2 on windows. This should already be covered in the readme, I think


#4

Thanks! I installed msys2 following the instructions in https://www.msys2.org, but maybe it’s to do with environment variables not set correctly…


Oct 2018 - How to update Fuse Studio Preview (local preview) to use latest Fuselibs and Uno
#5

Yeah, it looks like bash needs to be in path


#6

Though this issue is unrelated to aeq´s post about “Fuse Preview not working with the latest Fuse-libs and Uno”. Can we get an insight on that?


#7

Hello! I installed Bash and it works ok in the command line, but the same error comes up. If I run “bash scripts/build.sh” instead of “make release”, I get this:

C:\Users\Matti Tihveräinen\Documents\GitHub\uno>bash scripts/build.sh
: No such file or directorycripts/common.sh
scripts/build.sh: line 5: $'\r': command not found
scripts/build.sh: line 12: $'\r': command not found
scripts/build.sh: line 14: syntax error near unexpected token `$'do\r''
'cripts/build.sh: line 14: `for arg in "$@"; do