MapView Zoom property doesn't have any effect


according to and I should be able to set the zoom level on a MapView.

I tried <MapView Zoom="{ZoomLevel.City}"> and <MapView Zoom="1.0"> but the zoom level is always set to the maximum zoom out.

Additionally, you might want to expand the documentation at so that it demonstrates on how to get a reference to the MapView to call setZoom(1.0) on.

Thanks so much

Thanks for reporting this. Someone from the Fuse team will look at this right after easter vacation :slight_smile:


here’s a bit more information from my side.

  • Fuse v0.11.0 (Build 6172)

  • UX context for the MapView:

<Page ux:Name="map">
            <MapView Zoom="1.0">
                <MapMarker Label="Fuse HQ" Latitude="59.9115573" Longitude="10.73888" />


Anything new on this one? I’m building for Android btw.


Hey Kaih, burning through mapview issues today, one at a time. I’ll get back to you with an update in a little bit :slight_smile:

Hey Andreas,

thanks for the feedback. Looking forward to using the MapView :slight_smile:

Ok, so a Zoom of 2 is the minimum zoom, so that’s all the way out. 21 is the maximum zoom in. It’s a bit confusing, but ask Google about that :wink: Try with higher values and see if you have any luck. When I test here Zoom behaves as it should. “It works here” is the worst kind of feedback to get from a developer, I know, but indulge me :wink:

I’m going to do a pass on the MapView docs, as there are more Zoom changes coming in to unify iOS and Android, will also clarify this.

Hi Andreas,

thanks for taking a look. Unfortunately, setting the Zoom property to 2, 21 or any value in between doesn’t do anything in my Android project. The map is zoomed all the way out:

<App Theme="Basic">
            <MapView Zoom="21">
                <MapMarker Label="Fuse HQ" Latitude="59.9115573" Longitude="10.73888" />

I can confirm this on Android as well.

Just pushed a pretty major update to how values are propagated through both iOS and Android MapViews (including unifying how they read Zoom) which should make it into a release soon. Sorry it’s not working for you guys :confused: Can I ask which devices you are testing on?

Hi Andreas,

thanks for the update, sounds good.

I’m using a Galaxy S7 and a Nexus 4 to test this.

Nexus 6p, will also test on Samsung s4 and report back

Anything new on this one?