Local preview not rebuilding properly

I have the following problem: often times the preview build doesn’t update properly (doesn’t include the latest code) even though I use Rebuild (Ctrl + shift + R)

It usually happens like this:

  • see something is not working properly

  • make a fix

  • still not working; make another fix

  • still not working; make another fix

  • a few fixes later realize none of my fixes are included in the preview build I’m running

  • delete everything from the view I’m in

  • it still shows up in the preview build

Here is a screenshot from earlier: https://dl.dropboxusercontent.com/s/69wr2b0r6mdivgl/shot_171212_115233.png

I had a broken tag; I fixed it; it still compalined about it even after re-build.

I deleted almost every code from the view, it still complained about that (non-existing) tag.

Here are the Fuse processes running: https://dl.dropboxusercontent.com/s/x0vzdz3sdb3zekm/shot_171212_131217.png

OS: version: Windows 10

Fuse version: 1.4.0 (build 14778)

Solutions I tried:

  1. Reinstall fuse - did nothing but there is a possibility that my installed version
    might be broken (I had to clear the windows registries at some point to uninstall and reinstall fuse)
  2. Deleted the build folder process and retsrated - this worked at first, but then the problem still started occuring

Now, I realize this might be hard to debug, which is why I’m hoping this is a known issue or something that other people ran into.


Later edit: can a mod move this to Bugs? I accidentaly posted it in General.

Hi mircea,

we’ve seen this behaviour now and then on various Fuse builds, and are working constantly on improving how reify works. The usual medicine to get out of a broken state is uno clean + rebuild, not much else you can do. Sorry. We’re working on it.

You could try to upgrade to Fuse 1.5.0 (released today) and see if the situation improves with it.