LoadLibrary failed with error 1114: A DLL initialization routine failed.


I’ve tried to run Social Media Mock app on my Windows 10 PC, but when I try to preview on desktop, I instantly get the error message on the thread subject.

Build process completes successfully.

Hi, do you have the latest drivers for your graphics card?

Can you please try to start the preview from a terminal by doing fuse preview and paste the entire output of that command?


It has AMD Radeon 6700M, and AMD auto detect tool says it has the latest driver.

Error message appears as a small Windows dialog box, not in the console output.

Here’s fuse preview results:

C:\Users\Tiro\Desktop\social-media-screen>fuse preview
Connected to fuse daemon
Build started: FullCompile

Building project 'SocialMediaMock', target 'DotNetDll'

Build stage changed: Configuring
# Configuring
Uno: 0.9.3-Win32
Project: C:\Users\Tiro\Desktop\social-media-screen\SocialMediaMock.unoproj
Packages: UnoCore (0.16.4), Fuse.Designer (0.15.3), Uno.Collections (0.16.2), Uno.Geometry (0.16.2), Uno.Threading (0.16.4), FuseCore (0.15.3), Experimental.Physics (0.15.3), Fuse.Animations (0.15.3), Fuse.Drawing (0.15.3), Fuse.Drawing.Batching (0.15.3), Fuse.Drawing.Meshes (0.15.3), Fuse.Drawing.Planar (0.15.3), Uno.Net.Http (0.16.4), Experimental.Http (0.15.3), Fuse.Triggers (0.15.3), Android (0.16.3), ObjC (0.16.1), Experimental.iOS (0.16.1), Experimental.TextureLoader (0.16.2), Fuse.Elements (0.15.3), Fuse.Drawing.Primitives (0.15.3), Fuse.Drawing.Polygons (0.15.3), Fuse.Drawing.Paths (0.15.3), Fuse.Entities (0.15.3), Fuse.Gestures (0.15.3), Fuse.Navigation (0.15.3), Fuse.Shapes (0.15.3), Fuse.Controls (0.15.3), Fuse.Effects (0.15.3), Fuse.Physics (0.15.3), Fuse.BasicTheme (0.15.3), Fuse.Video (0.15.3), Fuse.Themes (0.15.3), Fuse.Desktop (0.15.3), Fuse.iOS (0.15.3), Fuse.Android (0.15.3), Fuse.Camera (0.15.3), Fuse.Storage (0.15.3), Fuse.Vibration (0.15.3), Fuse.Launcher (0.15.3), Fuse.Messages (0.15.3), Fuse.GeoLocation (0.15.3), Fuse.Scripting (0.15.3), Uno.Data.Json (0.16.2), Fuse.Scripting.Duktape (0.15.3), Fuse.Scripting.JavaScriptCore (0.15.3), Fuse.Scripting.Jurassic (0.15.3), Uno.Net.Sockets (0.16.2), Fuse.Scripting.V8 (0.15.3), Fuse.Reactive (0.15.3), Experimental.Bitmaps (0.16.2), Outracks.Simulator.Protocol.Uno (0.0.0), Outracks.Simulator.Reflection.Uno (0.0.0), Outracks.Simulator.Client.Uno (0.1.0), Uno.Data.Xml (0.16.2), SocialMediaMock (0.0.0)
(1.972,55 ms)

Build stage changed: Parsing source code
# Parsing source code
(183,13 ms)

Build stage changed: Compiling syntax tree
# Compiling syntax tree
(1.392,58 ms)

Build stage changed: Generating code and data
# Generating code and data
(4.853,38 ms)

Build completed in 8,41 seconds
    0 Warning(s)
    0 Error(s)
Build ended

Where does the exception appear? Can you take a screenshot? Could you please also try to do fuse build -v --run and see if you get the same error?

fuse build -v --run ends up ERROR: Target did not produce a runnable program

Oh, my fault, it should have said fuse build -v --run -t=dotnetexe.

It is running good with targeting .NET, Anders. Still reading the documentation, I did not notice the missing target argument, too. Sorry.


As Anders guessed, it’s caused by graphics card driver. The computer I’m using (HP Pavilion dv6 notebook) has 2 graphic adapters: An Intel and an AMD Radeon. Intel acts as a master card that passes control to AMD when high performance graphics is needed. This is called “switchable graphics”. You can set applications default mode on “Configure Switchable Graphics” on context menu displayed on desktop area.

Preview is running when I’ve set Fuse.exe to AMD Radeon 6770M.