Issues with hikr tutorial

Hello. I just started using Fuse Yesterday and have dl’ed and installed what I needed to install. So this Morning I’m opening up Fuse and following instructions on the hikr tutorial only to hit a few problems, which I already fixed (installing Sublime Text and the Fuse-Atom plugin), but when I attempt to type the fuse create app hikr [optional path] command, I keep receiving a error message in the Terminal stating the Path is incorrect or can’t be found. Is there something I’m doing wrong, like using the wrong location of the Path?

By the way I’m using a Dell Inspiron 15 Laptop and the latest version of Fuse, which should be 1.5.0, and although I have no Phone plugged in and am using the Emulator, I do have a BlackBerry PRIV that I’ll use for my Android App testing. Any response and help would be wonderful, seeing as I’m at a standstill with the program and can’t work on anything at the moment.


if you ran a fuse create app hikr [optional path] command in Terminal, then that is of course bound to fail. You are expected to supply a valid (optional) path to that command, so that it knows in what directory to create the project.

That said, you don’t really need to use Terminal to get started with Fuse at all. You can just launch the GUI and create a project from it.

Yeah, I know. I had the file on the Desktop in a folder at the beginning (I also had to create a Desktop icon for it), but then moved it to the Root Directory after a Friend’s Son helped out a bit with redirecting the Source Code folder. I still wasn’t able to locate it, it was giving me the exact same error message as before, and I had removed and unzipped the file again before moving it.

As far as the GUI, there’s no place for me to type in any Commands, except in my Search Bar on my Laptop, so I don’t know how that works, even in Atom (which I do have DL’ed along with the Fuse-Atom Plugin, also moved to the Root Directory). I’m just starting out on all of this at the moment, seeing as this is my 1st experiment in Coding, and this isn’t the 1st Cross-Platform program I’ve tried, but it’s the easiest so far, which is why I’m being extra patient, so I ask that you do the same with me for a moment. I’m still stuck on Chapter 1 of the Tutorial because of this.

Thanks for your time and assistance. Most appreciated.

Perhaps you should just read the Installation and Quickstart article carefully before diving into the Tutorial.

I did–that’s why I’m asking about this part. :smiley:

One thing I DIDN’T do Yesterday that I just did was open the project in Atom. I was so fully-concentrated on Fuse not yielding any results that I didn’t think about using Atom to open/edit it. I do have to ask if I’ll see any of the changes that I make to the script in Fuse GUI, or will I have to use my Phone? I plan on it anyways, but seeing as it has the iOS feature in the display, it wouldn’t hurt to have a visual on both an Android and iOS device.

Everything you’ve asked so far is already answered on our introductory docs. See Introduction to Fuse and feel free to click around some more in the left menu, you’ll find plenty of useful information there.

What th–

–how did I miss this? This is TOTALLY what I was looking for! Thanks! If I have any other questions, I’ll create another Thread for it!

Sure, feel free to ask. However, before you do, please make sure you’ve done some research.