Issue with preview android

Hi, I’m new in Fuse, I installed fuse completely step by step based on fuse document. Also installed android SDK , NDK &… via fuse install android. Now when type in termianl “fuse install -s android” everything is OK but I cant preview or export my app to android devices but local preview is OK!

I got this error when build for Android.

Hi, it looks like you have a problem with your Xcode Command Line Tools. (Even if you’re not building for iOS, Xcode is what provides the build tools on OS X.)

Could you please try doing just gcc in the terminal, and see if you get a pop-up from Xcode helping you to solve this? If not, you can try to do xcode-select -p to verify your Xcode Command Line Tools installation, or xcode-select --install to install them.

Hi when I use gcc terminal returns >> clang: error: no input files

I installed XCode from app store but again when i try to preview for Android I got error:

Today I installed android sdk 19 , now I’m able to build application for android. Also when I use --run it run on my phone automatically. But not be able to use preview command and got error (previous post)

Are you saying that the same app that you are able to run on your phone with fuse build --target=android --run, fails with the error: stray... errors when you do fuse preview? If so, could you please try to do uno clean and see if that helps?

Thanks Anders, Yes I have a problem with same application. It doesn’t help me. I tried with my own app & Fuse examples but again I got the error when use fuse preview

Do these errors always com from Android.Base.g.cpp? Or are they sometimes reported for other files too? Could you please send us a copy of Android.base.g.cpp so we can have a look at it? You can upload it to

By the way, which version of Fuse are you running? You can find that out by running fuse --version or looking at the menu bar.

I don’t know why , but now everythings is OK! I didn’t any change to my sdk , fuse config and … after my last post. but when I tried some minuets ago it worked fine.

if Android.Base.g.cpp helps you I’ll send you. Also I use the last version of fuse until know Fuse version 0.9.5 (build 5424)

Thanks for your support.

Huh, that’s curious! If you have a version of Android.Base.g.cpp from a build that failed, I would still appreciate to have a look at it. But if you don’t, or if it is a hassle to find, don’t bother.

Thanks for sticking around and not giving up on us! :slight_smile: