How to Change the Row of a String Without a Space


I have been testing strings for chatting.

If you are outputting a string within a fixed width, and you enter a string that does not contain spaces, no line conversion occurs.

      var Observable = require('FuseJS/Observable')
      var text = Observable('ABCDEFGHIJKLMNOPQRSTU TESTCODE')
      module.exports = {
      text: text
    <Panel Color="#BEFFDA" Width="120" Alignment="Center">
        <Text ux:Name="tex" Value="{text}" TextWrapping="Wrap" />

In the source, output without space, such as “ABCDEFGHIJKLMNOPQRSTU”, will result in “…”.

I want the rest of the string to be printed on the next line without “…” or truncation.

My fuse version is 0.37,

This source code worked at 0.35 in the direction I wanted.

However, this does not happen at 0.36 and 0.37.

Hi operate2v,

and thanks for reporting. This is an effect of the new Harfbuzz text renderer that was introduced as default in Fuse 0.36. There is now an internal ticket to make it wrap long “words” without spaces and you’ll get notified when there’s some progress on that.

As for a current workaround, your best bet is to add spaces to such longs words yourself, before passing the content out to UX.

Also, could you please check and report how this exact code appears on target devices?

My devices are iPhone 7 and Galaxy Note 3.
Both devices output the same result.